Find the answer to your Linux question:
Results 1 to 10 of 10
Hi all... I have the Wheezy release of Debian and it is on three DVD's that I burned. I FTP'd the iso file down from the debian.org site. I seem ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    214

    ISO size - 4.7 G disk size = 4.3 Fix?


    Hi all...

    I have the Wheezy release of Debian and it is on three DVD's that I burned. I FTP'd the iso file down from the debian.org site. I seem to have recurring problems with the 3rd DVD such as files not there and so forth.

    After investigation I noticed that the downloaded file is 4.7 G and the DVD is imprinted with 4.7 G, but when I put it in the drive, Brasero shows 4.3 G available. However the software continues and it shows a successful completion.

    I have looked over the docs and did see where some downloading software has a problem, but mine shows the proper sizes. Is this something that should be put in as a bug? Since I don't seems to be able to let aptitude know to go to the Internet for the files, it sometimes just hangs in the "replace /media/cdrom0 with Debian testing i386 3 disk and press enter" This keeps comming up when I put the disk in even though I've loaded packages from it before. When I look at the disk, I can see there are missing files.

    I'm starting to think it needs to go into the bug report. If it's true that the DVD can hold 4.7 G and you take out some for disk architecture, then that may leave you with less available space. It is the largest disk in the group.

    Any suggestions?

    Do we have any aptitude wizzards out there that can advise me on getting it to fetch from the Internet instead of the DVD's?

    Thanks...

    Jack

  2. #2
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    Is there a reason for using the DVD iso instead of the CD iso?

    Generally, the DVD is better suited to folks without easy online access to the repos.

    Can you post what's in /etc/apt/sources.list?

  3. #3
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    214
    I use DVD's because I have no reason to carry a dozen CD's around. Why should it make a difference? At the time I did not have Internet access, so that's where it started. And I have DVD's no CD's. If this is a supported medium, why would there be problems? It's like why not use floppies, you know that one, same reasoning. It's old technology, in fact I'm looking at moving to Blu-ray with 25G/disk then I need only one.

    However here is my sources.list file:
    Code:
    #
    
    deb cdrom:[Debian GNU/Linux testing _Wheezy_ - Official Snapshot i386 DVD Binary-1 20130401-06:23]/ wheezy contrib main
    
    deb cdrom:[Debian GNU/Linux testing _Wheezy_ - Official Snapshot i386 DVD Binary-2 20130401-06:23]/ wheezy contrib main
    
    deb cdrom:[Debian GNU/Linux testing _Wheezy_ - Official Snapshot i386 DVD Binary-3 20130401-06:23]/ wheezy contrib main
    
    
    deb http://security.debian.org/ wheezy/updates main contrib
    deb-src http://security.debian.org/ wheezy/updates main contrib
    I didn't know if I could just comment out the DVD entries to get it to go on-line. I would rather have aptitude go on-line, but don't seem to know how to do that. I don't seem to be able to find what really should be in this file. Most of it was created by the installation program.

    Thanks for your assistance.

    Jack

  4. #4
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    When doing an install from a CD/DVD and without an internet connection, the setup leaves the install CD/DVD (deb cdrom) uncommented as your repo source. An install with an internet connection comments it out while adding the online sources.

    Below are Wheezy's sources for the sources.list file; uncomment deb-src if you need source pkgs. If you plan to stay with online updates, you might wanna comment out the 'deb cdrom' sources... leaving them uncommented is okay but aptitude will continue to show you the DVD's pkg versions as well as the newer repo versions.

    In a terminal, to update the pkg list from the repos online:
    Code:
     sudo apt-get update

    Code:
    # Wheezy Main
    deb http://ftp.us.debian.org/debian/ wheezy main non-free contrib
    # deb-src http://ftp.us.debian.org/debian/ wheezy main non-free contrib
    
    # Wheezy Security
    deb http://security.debian.org/ wheezy/updates main contrib non-free
    # deb-src http://security.debian.org/ wheezy/updates main contrib non-free
    
    # Multimedia
    deb http://www.deb-multimedia.org wheezy main non-free
    # deb-src http://www.deb-multimedia.org wheezy main non-free

  5. #5
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    214
    Thanks that helps alot. Although I still get some errors:

    Code:
    W: Failed to fetch http://ftp.us.debian.org/debian/dists/wheezy/updates/main/binary-i386/Packages  404  Not Found [IP: 128.30.2.36 80]
    
    W: Failed to fetch http://ftp.us.debian.org/debian/dists/wheezy/updates/contrib/binary-i386/Packages  404  Not Found [IP: 128.30.2.36 80]
    As the above shows when I use the ftp.us.debian.org address...

    Any other suggestions? Like how to make aptitude find packages that I can find on the debian web site but when I search for them in aptitude they are not found? Like gpredict? This is a Ham Radio satellite tracking program that you can find via the packages search tool on Debian, but not in aptitude..

    Thanks

    Jack

  6. #6
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    As the above shows when I use the ftp.us.debian.org address...
    Any other suggestions?
    That's the correct address. They might have taken main and contrib offline to upload a new list and/or pkgs. Try again in an hour or three and it'll probably work fine.

    Forgot to mention the US country code. If you live in another country, edit in the two digit letters for your country.

    ---

    Saw your other post about printing... at 'localhost:631/admin' click on 'Manage Printers' and then click on your printer. In the 'Administration' drop-down tab, click on 'Set Allowed Users' and add your name. Be sure to click 'Allow these users to print.'

    If that doesn't work, go to /etc/group, add yourself to the lp and lpadmin groups and then you'll be able to set Allowed Users. You may need to log out/in to take effect. If a shared computer, you might wanna remove yourself from lpadmin after setting up all the Allowed Users.

  7. #7
    Just Joined!
    Join Date
    Jun 2012
    Posts
    32
    you may try downloading the third DVD by torrent

  8. #8
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    214
    I've ttied various download methods, but it always comes to the same problem. It seems the size is correct, but when you want to put it on DVD the availble space is only 4.3 when the ls filesize is 4.7. Seems that Brasero doesn't complain when it goes to write and when it does it something under 4.5 in size. When I go to use it, apt-get complains that i have the wrong disk inserted. Is there a way to expand it or tell apt that it's on the hard drive?

    Thanks
    Jack

  9. #9
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    214
    I seem to get this repeatably. Not just now and then. I live in the US, SW Arizona.

    The print problem, I think is a spooler or something. When I go into the display and type printer I get two selections availabe, one is printers the printer, one shows the Epson printer and I think it CUPS and the other states I don't have the nessary software running, with a short list of items. I don't know why it won't just ship it out to the printer that is in the network. It won't let me ad any printer.

    I'm on the wheezy release which is differnt than squeeze.

    Jack

  10. #10
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    Not sure what to suggest about downloading/burning the DVD. I tried the same thing a few months ago just to see what was on the DVD. It didn't work for me, either... the download finished at about 80% like it did for you. If you've got a viable internet connection, you're better off using it.

    This is a Ham Radio satellite tracking program that you can find via the packages search tool on Debian, but not in aptitude.
    Everything HERE is available from the Wheezy repo with aptitude, or any other Pkg Mgr.

    ---

    When I ran across your printer post it reminded me I needed to finish Wheezy... I installed it a while back but never set up the printer. It's an Epson 740 from the turn of the century and still works.

    The aptitude log from the installed pkgs is below; it's short because I don't use a desktop environment. With the printer on, I opened the browser to localhost:631/admin. I clicked 'Add Printer' and entered the root password. The 'Local Printers' showed 'EPSON Stylus COLOR 740 (EPSON Stylus COLOR 740)' and I clicked on it then 'Continue' and finished the set up. After that, I added myself to lp and lpadmin in /etc/group (I don't share this computer) so I (as user) can use it and make changes without a password.


    Aptitude 0.6.8.2: log report
    Sat, Apr 27 2013 13:28:31 -0700

    Will install 18 packages, and remove 0 packages.
    22.9 MB of disk space will be used
    ===============================================
    [INSTALL, DEPENDENCIES] bc:amd64
    [INSTALL, DEPENDENCIES] cups-client:amd64
    [INSTALL, DEPENDENCIES] cups-common:amd64
    [INSTALL, DEPENDENCIES] cups-filters:amd64
    [INSTALL, DEPENDENCIES] cups-ppdc:amd64
    [INSTALL, DEPENDENCIES] libcupscgi1:amd64
    [INSTALL, DEPENDENCIES] libcupsfilters1:amd64
    [INSTALL, DEPENDENCIES] libcupsmime1:amd64
    [INSTALL, DEPENDENCIES] libcupsppdc1:amd64
    [INSTALL, DEPENDENCIES] libgudev-1.0-0:amd64
    [INSTALL, DEPENDENCIES] libslp1:amd64
    [INSTALL, DEPENDENCIES] ssl-cert:amd64
    [INSTALL, DEPENDENCIES] ttf-freefont:amd64
    [INSTALL] cups:amd64
    [INSTALL] cups-pdf:amd64
    [INSTALL] fonts-freefont-ttf:amd64
    [INSTALL] ghostscript-cups:amd64
    [INSTALL] libgusb2:amd64

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •