Find the answer to your Linux question:
Results 1 to 6 of 6
"The devil is in the details." It happens that I've been working with computers for more than 30 years, and am not afraid of the command line, but only recently ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2013
    Posts
    5

    Apache misinstalled?


    "The devil is in the details." It happens that I've been working with computers for more than 30 years, and am not afraid of the command line, but only recently started a significant study of Linux. The sheer number of commands and options and scripts and utility programs is a bit overwhelming.

    This particular computer was an old WinXP machine that I used to download and burn a very recent set of Debian CDs ("Wheezy"). Then I swapped out the hard drive for a blank one (80Gb), and installed Debian. Gnome is OK, but it is so "spare" of features reminds me a bit of Windows 95, where, when it first came out, its best feature was the ability to simultaneously run a bunch of DOS boxes. Here, I open several Terminal windows, as needed.

    So far I have also managed to install gcc and a couple things that needed to be compiled, like Open Office. Along the way I found I wanted or needed things like a slightly friendlier text editor than vi ("leafpad"), some pkgconfig stuff, bzip2, 7zip, unzip, gzip (how many of those ARE there, anyway!? , GTK+, and so on. There were various issues that arose, for which I was able to find answers on the Web, thanks to others also running into those issues.

    This latest issue, however, has me stumped. It happens that for Windows there is a web-server package called "WAMP", which is rather like "LAMP" except the "W" stands for "Windows". I've been toying with a web-site project for a couple years, as time allowed, and mostly didn't need to concern myself with much about how to use Apache. It basically just worked.

    So, I download and install Apache on this new Debian system, and the IceWeasel browser obligingly connects to the server and presents the default "It works!" page. But after I imported my directory-structure for my future web site, I got 403-Forbidden errors when trying to access anything not in the "www" directory.

    The fix SEEMS easy enough. I should be able to enable access to various subdirectories in the "httpd.conf" file. Unfortunately, it hasn't been that easy. Somehow I have a working Apache server that doesn't have a file named "httpd". Nor is there an "httpd.conf" file. Nor is there an "httpd.pid" file. It took a couple days of hunting just to discover that, somehow, all the relevant files received names begining with "apache2" instead of "httpd", when the web-server software was installed.

    So now I can describe the problem that led to this post. No, it is not yet about accessing the subdirectories. There is a file "apachectl", and there is another file "apache2ctl". At least one of them is supposed to be able to turn off and turn on the web server. It doesn't work! From the error messages I get, such as "httpd not running, trying to start", I believe it is safe to say that apachectl doesn't know that the actual sever program is named "apache2" instead of "httpd". And so I have to reboot the computer to ensure that I get a freshly-started web server, paying attention to my experimental edits of "apache2.conf", in order to find out what works, with respect to those 403 errors.

    Linux is famous for not needing so many reboots as Windows! But not for me, apparently, unless apachectl or apache2ctl can be fixed.

    Or, should I try uninstalling Apache entirely and try again with a new install of it? Any pointers that can be offered, regarding ensuring that I actually get "httpd"-named files during the new install, would be appreciated! Thanks in advance!

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,638
    The best way to install software on Linux is using the package manager. "Downloaded and installed" implies you tried the Windows way... I would uninstall the Apache you installed and then run
    Code:
    apt-get install apache2
    as root. Once this is done, your config files will be in /etc/apache2. If I recall correctly, you use
    Code:
    service apache2 start|stop|restart
    also as root to control it.
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,638
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2013
    Posts
    5
    As it happens, I don't recall exactly what I did to install Apache, other than to follow some instructions that came with the download, regarding Linux.

    So I decided to go ahead and uninstall it, and looked up how to do that, and, hmmm..., Gnome got uninstalled too!
    A rather too-generic set of uninstall commands, they were!

    It was kind of interesting, though. The Installer that came with Debian is what had originally installed Gnome, and I described it as "spare".
    After using apt-get to reinstall it, there were quite a few more programs that came with it, than before. The only one that didn't work was LibreOffice;
    it didn't install properly, seemingly due to a bad file (may have glitched when I downloaded it to burn the CDs).
    It doesn't really matter since Open Office is still there.

    I should mention that previously I had copied all twelve of those CDs to the hard disk, and edited a config file so that apt-get could update itself from all of them.
    Perhaps that is why Gnome, when it installed, was able to include more stuff than just what came on CD#1, when Debian was originally installed
    (a different glitch, during that install, prevented me from changing CDs --the tray of the CD-ROM drive would not open!--
    so apt-get didn't have complete info at that time).

    Anyway, after getting Gnome back I re-did Apache with apt-get, and this time the key files had names beginning with "httpd".
    Then I spent several hours trying to solve my earlier problem, regarding 403 errors. I just found something that worked a little while ago,
    and decided it was time to reply to the replies in this Message Thread. Thank you. I will try to bother folks here with noob questions
    as seldom as possible, and I expect it will be a while before I feel comfortable enough to try offering answers to others' problems.

    Next task for me: get PHP installed...(maybe I'll be back here sooner than I want!).

    Before I end this message I would like to make a small complaint. In the time it took to write it, the Server timed me out and I had to log in again. Bah!

    A final "KUDOS!" to the Linux core developers, before I end this message.
    This particular computer has no video card; it has on-the-motherboard graphics stuff.
    It was, years ago, built to be a sever, and has only PCI expansion slots, and no AGP slot.
    My monitor is quite nice and is able to do 2048x1152 resolution.
    When I was running WindowsXP, there was no driver available that could make the graphics system run at that resolution.
    The hardware was quite capable, because one of the offered resolutions was 2048x1536 (which is too much for my monitor).
    When Debian was installed, though, I noticed that it had auto-selected a fairly fine screen resolution,
    and of course I had to track down what mode it chose.
    2048x1152! Hooray!! Thank you!!!

  6. #5
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    You might read the link below specific to installing php on Debian:

    PHP: Debian GNU/Linux installation notes - Manual

    The easy way to install a LAMP server with Debian and derivatives is: apt-get install apache2 php5 libapache2-mod-php5

    You could check the tutorial below. It also explains installing mysql and phpMyAdmin if you want those.

    Howto Install LAMP in Debian Sqeeze | Unixmen

  7. #6
    Just Joined!
    Join Date
    May 2013
    Posts
    5
    Well, I got PHP installed and working.
    In theory I should talk about it in a different Message Thread than this one,
    but there is one little detail, about the install process,
    that actually is relevant to this particular Thread.

    I had to re-install Apache all over again!
    The install process for PHP recommended compiling Apache,
    with a specific feature to enable easy communication between
    Apache and PHP. So, that is what I did. Since it works,
    I'm not especially complaining.

    Next up: Mariadb instead of MySQL...
    Among others, I don't like Oracle's ownership of MySQL.
    And since the Mariadb folks claim that it is designed to
    "drop-in/replace" MySQL, I figured, "why not try it?"
    We shall see how it goes. I've already seen some horror
    stories about trying to get it to mesh with Apache and PHP....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •