Find the answer to your Linux question:
Results 1 to 4 of 4
Hey guys, I'm a total noob, setting up a Raspberry Pi running a customized version of Debian called RaspyFi. I tried asking this question on the Raspberry Pi forum but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2013
    Posts
    2

    How to mount HFS+ network share from OS X volume


    Hey guys, I'm a total noob, setting up a Raspberry Pi running a customized version of Debian called RaspyFi. I tried asking this question on the Raspberry Pi forum but received no response.

    I'm want my Pi to act as a sort of Airport Express for streaming music to it. I've setup everything using the latest RaspyFi build. Locally hosted music (on the SD card) files play fine with mpd and I can stream music to the Pi from my Macs with Shairport. The problem is that I can't get my main music collection to be recognized in mpd because I don't know how to mount the networked volume on Linux.

    I have samba file sharing is setup correctly on my Mac Mini running OS X 10.8.4 but I can't figure out how to get the Pi to mount it. The volume is an external USB drive, formatted HFS+ (non-journaled). I installed hfsprogs as well.

    These are some of the many commands I've tried:

    sudo mount t cifs o username=XXXX,password=XXXX //10.0.1.99//Volumes/MUSIC/_MUSIC_LIBRARY /mnt/nas
    mount error(22): Invalid argument
    Refer to the mount.cifs( manual page (e.g. man mount.cifs)

    sudo mount -t hfsplus -o username=XXXX,password=XXXX //10.0.1.99/dev/disk2s2/_MUSIC_LIBRARY /mnt/nas
    mount: special device //10.0.1.99/dev/disk2s2 does not exist

    sudo mount -t smbfs -o username=XXXX,password=XXXX //10.0.1.99/_MUSIC_LIBRARY /mnt/nas
    mount: unknown filesystem type 'smbfs'

    What am I missing here? I'd really like to get this finished as it's nearly the last piece of the puzzle for this first time Linux user.

  2. #2
    Just Joined!
    Join Date
    Jun 2013
    Posts
    5
    mount.cifs //192.168.1.1/Media /mnt/network -o username=memeka,password=********,sec=ntlm

  3. #3
    Just Joined!
    Join Date
    Jun 2013
    Posts
    2
    Quote Originally Posted by asux View Post
    mount.cifs //192.168.1.1/Media /mnt/network -o username=memeka,password=********,sec=ntlm
    Thank you, that seems to have moved me closer to getting this share mounted! Now I am having a different problem. When I send the above command, I get this response:

    mount.cifs: permission denied: no match for /mnt/nas found in /etc/fstab

    Here is the fstab entry I have associated:
    "//10.0.1.99/_MUSIC LIBRARY" /mnt/nas cifs username=******,password=******,uid=mpd,file_mode= 0644,dir_mode=0755,iocharset=utf8,rsize=130048,wsi ze=4096 0 0

    Any further ideas?

  4. #4
    Just Joined!
    Join Date
    Jun 2013
    Posts
    5
    are u root user ?
    the best way to get help i have found is copy paste errer in to google if you have not fixed it .give me a reply if you are still stuk .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •