Find the answer to your Linux question:
Results 1 to 6 of 6
I've moved the OS from one drive to other acording to this tut: Raspberry Pi ? View topic - HOWTO: Move the filesystem to a USB stick and it worked ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2012
    Posts
    115

    I screwed it up, now I need help also.....


    I've moved the OS from one drive to other acording to this tut:
    Raspberry Pi ? View topic - HOWTO: Move the filesystem to a USB stick

    and it worked for a few hours but them started to spam error messages.
    I've rebooted the pi and it worked again but soon like 1 or 2 minutes later it has sent like 100 messages again saying this:

    Message from syslogd@raspberrypi at Jul 7 11:09:46 ...
    kernel:[ 612.896008] journal commit I/O error

    and them

    [119.737956] EXT4-fs error (device sda1): ext4_find_entry1209: imode #19136519: comn crom: reading firectory Iblock 0

    and I just cant do any thing... cant use any bash command and login doest work on ssh not even the reboot comand......

    Why? How to solve this?

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,882
    You might have a slightly damaged flash memory device in your pi. All I can suggest it that you reboot into single user mode and run fsck - or put the memory card/stick into a regular PC and run fsck there.

    If there are errors, it might be possible to mark the bad sectors, recover the data and carry on as if nothing happened.

    You might also want to consider backing up all your /home/<user> data to a big computer and re-installing the flash device from scratch, configuring it how you want, then copying your data back. It might seem a bit drastic to do this, but as long as your own data is backed up correctly, it might prove to be the safest and cleanest way to recover.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Newbie
    Join Date
    May 2012
    Posts
    115
    Ok Ill try to first run the fsck but how can I put the linux into single user mode?

  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,882
    Normally you just need to reboot and put a '1' or 'single' at the end of the kernel boot line through grub or lilo or whatever bootloader you're using.
    Linux user #126863 - see http://linuxcounter.net/

  5. #5
    Linux Newbie
    Join Date
    May 2012
    Posts
    115
    I've done both of the options and it happens again....

  6. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,882
    It may be that it's too screwed up to do much with. My recommendation at this point would be to restart with a fresh system. If you load the device on another computer, you can copy off any user data. Then you can install Debian from scratch on the device you're using (formatting it if necessary) and then copy back the user data. You may, of course, need a new flash device to install it onto - try the old one, but if you're suffering corruption, then I'd suspect a hardware failure first.

    The only other suggestion I can make is that you try to copy the filesystem again from its original source. Perhaps something went wrong during the original copy.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •