Find the answer to your Linux question:
Results 1 to 7 of 7
I'm following those instructions howtoforge dot com/encrypt-your-data-with-encfs-debian-squeeze-ubuntu-11.10 and all is fine, but when i mount it and try to access the decrypted folder it says permission denied in the terminal ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4

    Angry Can't access EncFS mounted volume


    I'm following those instructions
    howtoforge dot com/encrypt-your-data-with-encfs-debian-squeeze-ubuntu-11.10
    and all is fine, but when i mount it and try to access the decrypted folder it says permission denied in the terminal and is not even visible in Dolphin.

    I can see it only when root, but the owner is user and the permissions are that the owner should be able to view & modify

    p.s.
    the mount command i can execute only with sudo infront, because otherwise the system don't have access to fuse if that matters

    also i tried running the initial setup command with sudo as well, then the created directories are root owned, but when i change that it's still the same story and i can't access the decrypted folder at all, if not root.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    Have you tried to add this to /etc/fstab? If so (or even if not), what are the mount options you used?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4
    No, i don't even know what is this

    i mount the same way i set it up
    i run
    encfs ~/encrypted ~/decrypted
    the first time it creates
    when you run the same line again it asks for password and mounts
    that how i mount
    nothing else

    i thought that's how you are supposed to mount?

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    You should be able to specify the password in the entry for this device in /etc/fstab so that it can be auto-mounted when the system is started up.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4
    alright, but i would like to first make the manual mount work correctly

  6. #6
    Just Joined!
    Join Date
    Sep 2013
    Posts
    4
    please help

  7. #7
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    Read the mount man page.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •