Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
My new USB memory stick can't be unmounted. when I try to do so, the error message is: umount: /media/memstick: device is busy umount: /media/memstick: device is busy Please check ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8

    USB memory stick can't be unmounted


    My new USB memory stick can't be unmounted. when I try to do so, the error message is:
    umount: /media/memstick: device is busy
    umount: /media/memstick: device is busy
    Please check that the disk is entered correctly.

    the memory stick is entered correctly, and no process uses it.
    some times the line "Please check that the disk is entered correctly." gets printed, and sometimes it isn't.

    also, the device name sometimes changes from /dev/sde1 to /dev/sdf1. I haven't figured out on what occasions exactly it does this. The change seemingly occurs at random times.

    I'm running Debian Sid.
    what can I do about this?

    thanks in advance for help!

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    make sure you're not inside /media/memstick when you unmount
    there's also this one command which totally kills anything touching a certain device, but i forget what it is.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8
    I'm not in /media/memstick when I umount, and it still doesn't work.

  4. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Some program somewhere is probably accessing the mountpoint. Make sure you didn't hide a terminal that's cd'd to that dir or leave something open that was using a file in that dir. You can probably use 'umount -f' to unmount it forcefully, but this is not the recommended COA.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8
    I tried the "-f" option before, and it doesn't work either.
    I'm pretty sure that I'm not in the mounted directory, since all did was just a 'mount /media/memstick' and 'umount /media/memstick'

  6. #6
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    I have seen the exact same thing here. If you write something to the disk, it is always "busy". If I do not write something to the disk, I can umount it as normal. I did a little bit of google searching, but didn't find anything.

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8
    Actually, for me the disk also says it's busy when I don't write anything to it

  8. #8
    Just Joined!
    Join Date
    Jan 2005
    Location
    Oxford, UK
    Posts
    2
    Hi,

    Someone mentioned a command to check/kill what is locking the device - the command is 'fuser'

    eg:

    fuser -v -m /media/memstick

    There is also an option to auto-kill the tasks, but I think you want to investigate manually.

    If you want to know what Linux is up to when it allocates the device names, these are done on a first-come first-served basis, but unless you have another removable drive you should get the same one each time. There will be some cryptic explanation in the output of dmesg - you should check it out.

    HTH - TIM

  9. #9
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    fuser /media/memstick
    will give you the process that uses the device,

    here's
    a good place to learn fuser, you could also get info from
    Code:
    man fuser
    dont hesitate to ask for more information if ever those reading dont satisfy you [/url]
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  10. #10
    Just Joined!
    Join Date
    Jan 2005
    Posts
    8
    Well, fuser says that no process is using /media/memstick:

    $fuser
    /media/memstick/:
    $


    Also, I can't get filenames longer than 8 char's on the drive with linux. It is formatted with FAT. How can I fix that?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •