Find the answer to your Linux question:
Results 1 to 7 of 7
Ok, I know that hardware isn't really what this site is about, but I need help with something that only dedicated Linux users are all-too familiar with. After a voluntary ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    12

    Cannot boot from USB


    Ok, I know that hardware isn't really what this site is about, but I need help with something that only dedicated Linux users are all-too familiar with.

    After a voluntary hiatus from owning a computer, I have purchased a Dell Inspiron laptop (basic computer, no hating please).

    This laptop has the great Evil that is Windows 8 [Spits]

    I was dumbfounded to learn it does NOT have default support for booting from usb (I think, I could be wrong). Anyway I am currently going to attempt to update the bios, if possible.

    To be perfectly honest the main problem right now is that 2 different versions of Unetbootin, and the dd command on my dads linuxbox don't actually install Crunchbang (FTW) onto the USB, and I have no idea whats going on.

    This thing has legacy mode, and UEFI something or other, and I don't know what any of this new crap is.

    Help Please!?

    Thanks in advanced.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    If you purchased this computer new and it had windows 8 pre-installed, then it likely has something called 'Secure Boot' which you can access and will need to disable in the BIOS and possibly enable 'Legacy Boot'. If it is a new computer, it should have the ability/option to boot from a usb.
    Did you use the windows version of unetbootin on your windows 8 and the Linux version on your dads computer? Did you get any warning/error messages while using unetbootin and if so what were they?

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    12
    I used the newest Windows version and 393 under windows 8, I did not use unetbootin under Linux. I did not get any error messages, other than Unetbootin completing the task in 2 seconds. I have a 740mb ISO to write, so that can't be right.

    I have played around with the Legacy boot/Secure boot, I am not too sure about it atm...

    Windows 8 gives me an option to use a USB or DVD recovery when I shutdown...but the Bios/UEFI throws an error saying that USB is not supported. Is that because of the mode it is in? As opposed to: I need to update it in order for it to recognize the USB.

  4. #4
    Linux Engineer TNFrank's Avatar
    Join Date
    Jul 2013
    Location
    Crossville, TN. USA
    Posts
    829
    UEFI and Secure Boot are spawned form Satan, I refuse to buy any new laptop that has this crap or Windows 8 on it.
    That being said, there should be a key you can press at start up(normally the "esc" key) that will allow you to choose the boot device that you want. Also, 2 seconds does seem pretty fast to "burn" the iso live to USB. Something just isn't right there. If I were you I'd hit EvilBay and pick up an older pre-UEFI laptop to play around with Linux on, you can normally get em' for anywhere from $50-$150 depending on how "new" you'd want to go but I find that my $60/each HP nc6400's run Point Linux 2.2 pretty well and I didn't have all that UEFI or Secure Boot crap to stop me from installing my favorite Distro.
    Hope ya' get it sorted out, good luck, you'll need it.

  5. #5
    Just Joined!
    Join Date
    Jan 2013
    Posts
    12
    Thanks, there is a work around I found on the Crunchbang forums, but I'm "Crunching" and "Banging" my head on the desk yelling "I hate you UEFI/MICROSOFT"

    One thing at a time I guess.

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Creating a bootable flash drive with unetbootin in 2 seconds is a sure sign it was unsuccessful. I've not had problems using unetbootin but I don't use windows unetbootin or windows 8 except when I had it in VirtualBox. I would suggest you google to see if you can find some tutorials going step-by-step using unetbootin or posting each step you took and the results.

    On a computer that new with windows 8, you need to search the BIOS thoroughly as there should be an option to disable Secure Boot.

  7. #7
    Just Joined!
    Join Date
    Jan 2013
    Posts
    12
    That did the trick. All i needed to do was turn Legacy boot on, and Secure boot off. Now it works normally. This thread is SOLVED

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •