Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I tried to download a script from a server in UK (company server). This is the command I used : Code: #rsync -av --delete deployment.nta-monitor.com::installscripts/installer /root/new_debian_install However, I get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106

    Problem with rsync


    Hi,

    I tried to download a script from a server in UK (company server). This is the command I used :

    Code:
    #rsync -av --delete deployment.nta-monitor.com::installscripts/installer /root/new_debian_install
    However, I get this error :

    HTML Code:
    rsync:failed to connect to deployment.nta-monitor.com (192.xxx.xxx.xxx):Connection timed out (110)
    
    rsync error : error in socket IO (code 10) at clientserver.c(122) [Receiver=3.0.9]
    To resolve this problem, I tried a few things :

    1) Check the firewall port :

    Code:
    #egrep rsync /etc/services
    rsync                         TCP/873
    rsync                         UDP/873
    Apparently the ports are open.

    2) Then I test the connection with telnet. However, I get the error : telnet not found. When I attempt to install telnet & telnetd, I get the error No package telnet found.

    Could this be because I have not setup the repository?

    3) Then I create a file /etc/rsyncd.conf with these parameters :

    Code:
    max connections = 1
    log file = /var/log/rsync.log
    timeout = 300
    [cache]
    comment = Cache of Mongrels
    path = /usr/local/cache
    read only = no
    list = yes
    uid = nobody
    gid = nogroup
    #auth users = mongrel
    list = yes
    hosts allow = 127.0.0.0/8 192.168.0.0/24
    #secrets file = /etc/rsyncd.secrets

    4) I try to edit the file /etc/inetd.conf, with the parameters below, but this file is not available. Can I just create this file?

    Code:
    rsync stream tcp nowait root /usr/bin/rsync rsync --daemon
    5) I then attempted to start rsync, but I get this error :
    HTML Code:
    rsync daemon not enabled in /etc/default/rsync, not starting... (warning).
    But the directory 'default' does not even exist in /etc. What more the file rsync?

    Please help me resolve this issue.

  2. #2
    Just Joined!
    Join Date
    Oct 2012
    Posts
    13
    It looks like rsync is not listening on the other end. is there any specific reason you're not using rsync over SSH? it is the preferred way of using it these days. can you try using it via ssh, for example:

    Code:
    rsync -Wav -e ssh <user>@deployment.nta-monitor.com:/path/to/installer /path/where/you/want/it/transferred
    also, /etc/services has nothing to do that the ports are open. it is a plain ASCII file providing a mapping between human-friendly textual names for internet services. see `man services` for more information. instead, you may want to use `netstat` or `ss` to check if rsync is listening on the system

  3. #3
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106
    Somehow the /etc/default/rsync appeared the next day when I checked, I don't know how, and so I started rsync, and it worked.
    This time, however, when I run that command :
    Code:
    #rsync -av --delete deployment.nta-monitor.com::installscripts/installer /root/new_debian_install
    I get this error :

    HTML Code:
    ssh:connect to host deployment.nta-monitor.com
    port 22: Connection timed out
    rsync : Connection unexpectedly closed ( 0 bytes received so far ) [Receiver]
    rsync : error : unexplained error ( code 255 ) at io.c (605) [Receiver = 3.0.9]
    How do I start troubleshooting, and above all, how do I resolve this issue?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2012
    Posts
    13
    It means your source system was unable to connect to the target system over SSH on port 22. If SSH is running on non-default port on the remote host, you can use

    Code:
    # rsync -Wav -e 'ssh -p <PORT>' <user>@deployment.nta-monitor.com:/path/to/installer /path/where/you/want/it/transferred
    you can check on what port SSH is listening by either running:

    Code:
    # netstat -tunlp | grep ssh
    or

    Code:
    # ss -tnlp | grep ssh
    if there's a firewall in front of the target host, you may also want to check if it's not filtering your traffic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •