Find the answer to your Linux question:
Results 1 to 9 of 9
Hi all, Debian 7.3 was installed on a VM of VirtualBox and gnash was installed as default I can play video on Youtube but unable to play video on Newspaper. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804

    Iceweasel unable to play video


    Hi all,


    Debian 7.3 was installed on a VM of VirtualBox and gnash was installed as default

    I can play video on Youtube but unable to play video on Newspaper.

    $ sudo apt-get remove --purge gnash

    $ sudo apt-get install flashplugin-nonfree
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package flashplugin-nonfree is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'flashplugin-nonfree' has no installation candidate
    Found following link;
    flashplugin-nonfree has no release candidate?
    Debian User Forums ? View topic - flashplugin-nonfree has no release candidate?

    nano /etc/apt/sources.list
    adding:
    Code:
    deb http://www.backports.org/debian etch-backports main contrib non-free
    wget -O - http://backports.org/debian/archive.key | apt-key add -c
    Code:
    --2014-03-17 12:18:41--  http://backports.org/debian/archive.key
    Resolving backports.org (backports.org)... failed: Name or service not known.
    wget: unable to resolve host address `backports.org'
    gpg: no valid OpenPGP data found.
    I was stuck here. Please help. Thanks

    Rgds
    satimis

  2. #2
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,305
    Try again or replace backports.org and www . backports.org with backports.debian.org

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Quote Originally Posted by gregm View Post
    Try again or replace backports.org and www . backports.org with backports.debian.org
    Hi,

    # cat /etc/apt/sources.list
    Code:
    deb http://ftp.hk.debian.org/debian/ wheezy main
    deb-src http://ftp.hk.debian.org/debian/ wheezy main
    
    deb http://security.debian.org/ wheezy/updates main
    deb-src http://security.debian.org/ wheezy/updates main
    
    deb http://www.backports.debian.org/debian etch-backports main contrib non-free
    deb-src http://www.backports.debian.org/debian etch-backports main contrib non-free
    # wget -O - http://backports.org/debian/archive.key | apt-key add -
    Code:
    --2014-03-17 22:05:19--  http://backports.org/debian/archive.key
    Resolving backports.org (backports.org)... failed: Name or service not known.
    wget: unable to resolve host address `backports.org'
    gpg: no valid OpenPGP data found.
    # wget -O - http://backports.debian.org/debian/archive.key | apt-key add -
    Code:
    --2014-03-17 22:07:32--  http://backports.debian.org/debian/archive.key
    Resolving backports.debian.org (backports.debian.org)... 5.153.231.4, 140.211.15.34, 130.89.148.14, ...
    Connecting to backports.debian.org (backports.debian.org)|5.153.231.4|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2014-03-17 22:07:33 ERROR 404: Not Found.
    
    gpg: no valid OpenPGP data found.
    # wget -O - http://backports.debian.org/archive.key | apt-key add -
    Code:
    --2014-03-17 22:10:56--  http://backports.debian.org/archive.key
    Resolving backports.debian.org (backports.debian.org)... 5.153.231.4, 130.89.148.14, 140.211.15.34, ...
    Connecting to backports.debian.org (backports.debian.org)|5.153.231.4|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2014-03-17 22:10:57 ERROR 404: Not Found.
    
    gpg: no valid OpenPGP data found.
    satimis

  4. #4
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,305
    It really pays to check the dates on posts before following the instructions in them. Those posts were from 2008.

  5. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Quote Originally Posted by gregm View Post
    It really pays to check the dates on posts before following the instructions in them. Those posts were from 2008.
    Sorry, I couldn't find other postings with similar problem.

    satimis

  6. #6
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,305

  7. #7
    Linux Engineer docbop's Avatar
    Join Date
    Nov 2009
    Location
    Woodshed, CA
    Posts
    943
    I updated my Kali Linux with iceweasel last night here's real simple steps to do it.

    https://forums.kali.org/showthread.p...3-Simple-Steps

  8. #8
    Linux Engineer TNFrank's Avatar
    Join Date
    Jul 2013
    Location
    Crossville, TN. USA
    Posts
    873
    I simply go to Synaptic, type in "adobe flash" and install it and bingo, YouTube videos play no problem in Iceweasel.

  9. #9
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Hi all,

    I got my problem fixed..

    Edited /etc/apt/source.list
    Code:
    deb http://ftp.hk.debian.org/debian/ wheezy main contrib non-free
    deb-src http://ftp.hk.debian.org/debian/ wheezy main contrib non-free
    ....
    delete
    Code:
    deb http://www.backports.debian.org/debian etch-backports main contrib non-free
    deb-src http://www.backports.debian.org/debian etch-backports main contrib non-free
    $ sudo apt-get update
    $ sudo apt-get install flashplugin-nonfree

    rebooted iceweasel

    Now I can play video on Youtube as well on newspaper.

    Thanks

    Rgds
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •