Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, While starting one of the perl related service I am getting this error PHP Code: [ root @ mindlanf - 1 bin ] # ./start_STAF.pl Starting STAFProc : Failed to get D - Bus connection :  ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    4

    Failed to get D-Bus connection: Failed to connect to socket


    Hi,

    While starting one of the perl related service I am getting this error

    PHP Code:
    [root@mindlanf-1 bin]# ./start_STAF.pl
    Starting STAFProc:Failed to get D-Bus connectionFailed to connect to socket /org/freedesktop/systemd1/private: Connection refused
            
    [FAILED][root@mindlanf-1 bin]#
    [root@mindlanf-1 bin]# vi start_STAF.pl 
    please help me resolve this issue



    Thanks

  2. #2
    Linux Guru
    Join Date
    Dec 2013
    Location
    Victoria, B.C. Canada
    Posts
    1,660
    Is there a QT aspect to the script?

    It's probably a reasonable guess that something your script requires isn't properly installed - perhaps it works as another user but not as root?

    It's just guess work since you haven't posted the part of the script where it fails and haven't given much info beyond the error message but the QT lib uses D-Bus and a similar error can occur when it isn't properly installed.

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Posts
    4
    no Its not working for any user, i have provided some for info on this. hope this would be helpful


    PHP Code:
    [root@mindlanf-1 bin]# ./start_STAF.pl
    Starting STAFProc:Failed to get D-Bus connectionFailed to connect to socket /org/freedesktop/systemd1/private: Connection refused
            
    [FAILED][root@mindlanf-1 bin]#
    [root@mindlanf-1 bin]# vi start_STAF.pl
    [root@mindlanf-1 bin]#
    [root@mindlanf-1 bin]#
    [root@mindlanf-1 bin]# ntest
    ntest: *** Could not register with local STAF serviceSTAFNotRunning
    (Make sure STAFProc is running on mindlanf-1?)
    http://wikid.netapp.com/w/STAF#Starting_STAFProc
    20140409 133647 [] ****************************************
    20140409 133647 [] * Knowledge Base Help:
    20140409 133647 [] *     NATE Answershttp://answers.eng.netapp.com/search.html?redirect=search%2Fsearch&q=Could%20not%20register%20with%20local%20STAF%20service%3A%20STAFNotRunning&Submit=Search
    20140409 133647 [] *     Burt Query:   http://burtgoo2.eng.netapp.com/search?btnG=google&q=Could%20not%20register%20with%20local%20STAF%20service%3A%20STAFNotRunning&client=Burt&proxystylesheet=Burt&output=xml_no_dtd&filter=0&tlen=120
    20140409 133647 [] *     NATE User:    http://google-search.corp.netapp.com/search?&searchTarget=google&output=xml_no_dtd&lr=&oe=UTF-8&ie=UTF-8&x=0&y=0&ulang=en&sort=date%3AD%3AL%3Ad1&entqr=3&entqrm=0&ud=1&&getfields=*&proxystylesheet=Intranet_Coll&client=Intranet_Coll&q=dl-nate-user%20Could%20not%20register%20with%20local%20STAF%20service%3A%20STAFNotRunning&site=MAIL_ARCHIVES&num=50
    20140409 133647 [] * CONFIG ERRORCould not register with local STAF serviceSTAFNotRunning
    20140409 133647 
    [] * (Make sure STAFProc is running on mindlanf-1?)
    20140409 133647 [] * http://wikid.netapp.com/w/STAF#Starting_STAFProc
    20140409 133647 [] ****************************************
    20140409 133647 [] Did not get any tool usage informationSo we'll not log the lib and supress info
    [root@mindlanf-1 bin]#

    [root@mindlanf-1 bin]# lsb_release -a
    LSB Version:    :core-4.0-ia32:core-4.0-noarch
    Distributor ID: Fedora
    Description:    Fedora release 14 (Laughlin)
    Release:        14
    Codename:       Laughlin
    [root@mindlanf-1 bin]# uname -a
    Linux mindlanf-1 3.9.11+ #96 SMP PREEMPT Wed Oct 2 08:48:10 PDT 2013 i686 i686 i386 GNU/Linux
    [root@mindlanf-1 bin]# 
    Let me know if you need any other information

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Dec 2013
    Location
    Victoria, B.C. Canada
    Posts
    1,660
    Are you logged in to X? i.e. Running an X Desktop?

    It may be that this https://fedoraproject.org/wiki/Features/DBusPolicy is affecting STAF. Are you trying to run an up-to-date version?

  6. #5
    Just Joined!
    Join Date
    Jun 2011
    Posts
    4
    no i haven't logged into X desktop, now I am not getting this issue. my fedora machine was having 32 bit which was causing an issue I installed 64 bit and STAF service worked as expected. Any ways Thanks for your support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •