Find the answer to your Linux question:
Results 1 to 3 of 3
Dear all, Right after passing the BIOS, at the moment Grub is supposed to show it’s menu, my Debian Linux (Jessie/sid) system reboots. I have been googling and testing for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2014
    Posts
    2

    Grub2 keeps rebooting without showing menu


    Dear all,

    Right after passing the BIOS, at the moment Grub is supposed to show it’s menu, my Debian Linux (Jessie/sid) system reboots.

    I have been googling and testing for hours and can’t seem to find a way around the issue.

    How do I solve this?

    All testing and installing is done using Debian from 7.5 LIVE CD, command line only.

    I have set up my RAID as follows:

    Code:
    root#debian:~# cat /proc/mdstat 
    Personalities : [raid1] 
    md3 : active raid1 sda4[0]
          1458608960 blocks super 1.2 [2/1] [U_]
          
    md2 : active raid1 sda3[0]
          5238720 blocks super 1.2 [2/1] [U_]
          
    md0 : active raid1 sda1[0]
          102336 blocks [2/1] [U_]
          
    unused devices: <none>
    Partition table of running 4TB disk (only 1.5TB is currently used):

    Code:
    root#debian:~# parted /dev/sda
    GNU Parted 2.3
    Using /dev/sda
    Welcome to GNU Parted! Type 'help' to view a list of commands.
    (parted) p                                                                
    Model: ATA WDC WD40EFRX-68W (scsi)
    Disk /dev/sda: 4001GB
    Sector size (logical/physical): 512B/4096B
    Partition Table: gpt
    
    Number  Start   End     Size    File system  Name    Flags
     1      1049kB  106MB   105MB   ext3         boot    bios_grub
     2      106MB   1180MB  1074MB               swap
     3      1180MB  6548MB  5369MB  ext4         system
     4      6548MB  1500GB  1494GB  ext4         data
    Mountpoints are set:

    Code:
    root#debian:/mnt/etc# cat fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/md2	/		ext3    defaults,errors=remount-ro 0       1
    /dev/sda2	none		swap    sw              0       0
    /dev/md0	/boot		ext4    defaults	0       1
    /dev/md3	/data		ext4    defaults	0       1
    #
    /dev/cdrom	/media/cdrom0	udf,iso9660 user,noauto     0       0
    After chrooting /mnt I run grub-install:

    Code:
    root#debian:/# grub-install /dev/sda
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    Installation finished. No error reported.
    Code:
    root#debian:/# update-grub
    Generating grub.cfg ...
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    /usr/sbin/grub-probe: warning: Couldn't find physical volume `(null)'. Some modules may be missing from core image..
    done

  2. #2
    Just Joined!
    Join Date
    Apr 2013
    Posts
    69
    Quote Originally Posted by CtrlSPATIE View Post

    Code:
    root#debian:~# cat /proc/mdstat 
    Personalities : [raid1] 
    md3 : active raid1 sda4[0]
          1458608960 blocks super 1.2 [2/1] [U_]
          
    md2 : active raid1 sda3[0]
          5238720 blocks super 1.2 [2/1] [U_]
          
    md0 : active raid1 sda1[0]
          102336 blocks [2/1] [U_]
          
    unused devices: <none>
    Partition table of running 4TB disk (only 1.5TB is currently used):

    Code:
    root#debian:~# parted /dev/sda
    GNU Parted 2.3
    Using /dev/sda
    Welcome to GNU Parted! Type 'help' to view a list of commands.
    (parted) p                                                                
    Model: ATA WDC WD40EFRX-68W (scsi)
    Disk /dev/sda: 4001GB
    Sector size (logical/physical): 512B/4096B
    Partition Table: gpt
    
    Number  Start   End     Size    File system  Name    Flags
     1      1049kB  106MB   105MB   ext3         boot    bios_grub
     2      106MB   1180MB  1074MB               swap
     3      1180MB  6548MB  5369MB  ext4         system
     4      6548MB  1500GB  1494GB  ext4         data
    Mountpoints are set:

    Code:
    root#debian:/mnt/etc# cat fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/md2	/		ext3    defaults,errors=remount-ro 0       1
    /dev/sda2	none		swap    sw              0       0
    /dev/md0	/boot		ext4    defaults	0       1
    /dev/md3	/data		ext4    defaults	0       1
    #
    /dev/cdrom	/media/cdrom0	udf,iso9660 user,noauto     0       0
    Code:
    mdstat says that    parted says that   mtab says that
    md3=sda4            fs=ext4                <type>=ext4
    md2=sda3            fs=ext4                <type>=ext3
    md0=sda1            fs=ext3                <type>=ext4
    There's a mismatch type returned by parted against what's written in your /etc/fstab. This may be the reason of your problem.

  3. #3
    Just Joined!
    Join Date
    Jun 2014
    Posts
    2
    Lots of experimenting and research online leads to one quite dissapointing conclusion: Booting Debian with Grub2 from a 4Tb disk does *not* work yet.

    My workaround:
    - use a spare drive with an MBR instead of a GPT for Debian root.
    - keep all data and /home on /dev/md3
    - rsync the Debian root to /dev/md2 on an hourly basis

    If the issue is fuxed in future version of Grub, migrating to the RAID is hardly any work.

    Rsync script:
    Code:
    #!/bin/sh
    # 
    # -v verbose
    # -r indicates recursive
    # -a preserve attributes
    # -W whole file, instead of block
    
    SOURCE="/"
    DEST="/data/root_bak/"
    EXCLUDE="/root/bin/rsync_root_exclude"
    LOG="/var/log/rsync_root.log"
    
    echo "Started root dir backup from $0 at $(date +%Y%m%d%H%M%S)" > $LOG
    echo . >> $LOG
    echo . >> $LOG
    
    rsync -vraW --delete --log-file="$LOG" --exclude-from="$EXCLUDE" $SOURCE $DEST
    
    echo . >> $LOG
    echo . >> $LOG
    echo "Finished root dir backup at $(date +%Y%m%d%H%M%S)" >> $LOG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •