Find the answer to your Linux question:
Results 1 to 2 of 2
I am a new linux user and i have been trying to install iredmail to my VPS server via putty and constantly receive this error. What should i do to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2014
    Posts
    1

    iredmail Installation Error/usr/bin/ucf: line 238: !": event not found


    I am a new linux user and i have been trying to install iredmail to my VPS server via putty and constantly receive this error. What should i do to avoid this "/usr/bin/ucf: line 238: !": event not found error"?

    Code:
    root mail:~/mail/iRedMail-0.8.7# bash iRedMail.sh
    < INFO > Checking configuration file: /root/mail/iRedMail-0.8.7/config ... [FOUND]
    < Question > Use it for mail server setting? [y|N]y
    < INFO > Use config file: /root/mail/iRedMail-0.8.7/config for mail server setting.
    < INFO > Import installation process status from file: /root/mail/iRedMail-0.8.7/.status.
    < INFO > Installing package(s): mysql-server mysql-client postfix-mysql libapache2-mod-auth-mysql libapache2-mod-php5 php5-imap php5-json php5-gd php5-mcrypt php5-curl mcrypt php-apc php5-mysql postfix postfix-pcre postfix-cluebringer postfix-cluebringer-mysql dovecot-imapd dovecot-pop3d dovecot-lmtpd dovecot-managesieved dovecot-sieve dovecot-mysql amavisd-new libcrypt-openssl-rsa-perl libmail-dkim-perl clamav-freshclam clamav-daemon spamassassin altermime arj zoo nomarch cpio lzop cabextract p7zip rpm unrar-free ripole libmail-spf-perl phpmyadmin python-mysqldb libapache2-mod-wsgi python-jinja2 python-netifaces python-webpy awstats fail2ban bzip2 acl patch cron tofrodos logwatch
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Note, selecting 'php5-common' instead of 'php5-json'
    acl is already the newest version.
    altermime is already the newest version.
    amavisd-new is already the newest version.
    arj is already the newest version.
    awstats is already the newest version.
    bzip2 is already the newest version.
    cabextract is already the newest version.
    clamav-daemon is already the newest version.
    clamav-freshclam is already the newest version.
    cpio is already the newest version.
    cron is already the newest version.
    dovecot-imapd is already the newest version.
    dovecot-lmtpd is already the newest version.
    dovecot-managesieved is already the newest version.
    dovecot-mysql is already the newest version.
    dovecot-pop3d is already the newest version.
    dovecot-sieve is already the newest version.
    python-jinja2 is already the newest version.
    libcrypt-openssl-rsa-perl is already the newest version.
    libmail-dkim-perl is already the newest version.
    logwatch is already the newest version.
    lzop is already the newest version.
    libmail-spf-perl is already the newest version.
    mcrypt is already the newest version.
    libapache2-mod-auth-mysql is already the newest version.
    libapache2-mod-wsgi is already the newest version.
    mysql-client is already the newest version.
    mysql-server is already the newest version.
    python-netifaces is already the newest version.
    nomarch is already the newest version.
    p7zip is already the newest version.
    patch is already the newest version.
    php-apc is already the newest version.
    postfix is already the newest version.
    postfix-mysql is already the newest version.
    postfix-pcre is already the newest version.
    postfix-cluebringer is already the newest version.
    postfix-cluebringer-mysql is already the newest version.
    python-mysqldb is already the newest version.
    ripole is already the newest version.
    rpm is already the newest version.
    spamassassin is already the newest version.
    tofrodos is already the newest version.
    unrar-free is already the newest version.
    python-webpy is already the newest version.
    zoo is already the newest version.
    fail2ban is already the newest version.
    libapache2-mod-php5 is already the newest version.
    php5-common is already the newest version.
    php5-curl is already the newest version.
    php5-gd is already the newest version.
    php5-imap is already the newest version.
    php5-mcrypt is already the newest version.
    php5-mysql is already the newest version.
    phpmyadmin is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 37 not upgraded.
    15 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up php5-common (5.4.4-14+deb7u12) ...
    /usr/bin/ucf: line 238: !": event not found
    /usr/bin/ucf: line 238: !": event not found
    /usr/sbin/php5enmod: line 120: !": event not found
    /usr/sbin/php5enmod: line 120: syntax error near unexpected token `fi'
    dpkg: error processing php5-common (--configure):
     subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of php5-cli:
     php5-cli depends on php5-common (= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing php5-cli (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libapache2-mod-php5:
     libapache2-mod-php5 depends on php5-common (= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing libapache2-mod-php5 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of php5-curl:
     php5-curl depends on phpapi-20100525; however:
      Package phpapi-20100525 is not installed.
      Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
      Package php5-cli which provides phpapi-20100525 is not configured yet.
     php5-curl depends on php5-common (= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing php5-curl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of php5-gd:
     php5-gd depends on phpapi-20100525; however:
      Package phpapi-20100525 is not installed.
      Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
      Package php5-cli which provides phpapi-20100525 is not configured yet.
     php5-gd depends on php5-common (= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing php5-gd (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of php5-imap:
     php5-imap depends on phpapi-20100525; however:
      Package phpapi-20100525 is not installed.
      Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
      Package php5-cli which provides phpapi-20100525 is not configured yet.
     php5-imap depends on php5-common (= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing php5-imap (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of php5-mcrypt:
     php5-mcrypt depends on phpapi-20100525; however:
      Package phpapi-20100525 is not installed.
      Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
      Package php5-cli which provides phpapi-20100525 is not configured yet.
     php5-mcrypt depends on php5-common (= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing php5-mcrypt (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of php5-mysql:
     php5-mysql depends on phpapi-20100525; however:
      Package phpapi-20100525 is not installed.
      Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
      Package php5-cli which provides phpapi-20100525 is not configured yet.
     php5-mysql depends on php5-common (= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing php5-mysql (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of php5:
     php5 depends on libapache2-mod-php5 (>= 5.4.4-14+deb7u12) | libapache2-mod-php5filter (>= 5.4.4-14+deb7u12) | php5-cgi (>= 5.4.4-14+deb7u12) | php5-fpm (>= 5.4.4-14+deb7u12); however:
      Package libapache2-mod-php5 is not configured yet.
      Package libapache2-mod-php5filter is not installed.
      Package php5-cgi is not installed.
      Package php5-fpm is not installed.
     php5 depends on php5-common (>= 5.4.4-14+deb7u12); however:
      Package php5-common is not configured yet.
    
    dpkg: error processing php5 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of postfix-cluebringer-webui:
     postfix-cluebringer-webui depends on php5; however:
      Package php5 is not configured yet.
     postfix-cluebringer-webui depends on php5-pgsql | php5-mysql | php5-sqlite; however:
      Package php5-pgsql is not installed.
      Package php5-mysql is not configured yet.
      Package php5-sqlite is not installed.
    
    dpkg: error processing postfix-cluebringer-webui (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of php-apc:
     php-apc depends on phpapi-20100525; however:
      Package phpapi-20100525 is not installed.
      Package libapache2-mod-php5 which provides phpapi-20100525 is not configured yet.
      Package php5-cli which provides phpapi-20100525 is not configured yet.
    
    dpkg: error processing php-apc (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of squirrelmail:
     squirrelmail depends on libapache2-mod-php5 | php5 | php5-cgi; however:
      Package libapache2-mod-php5 is not configured yet.
      Package php5 is not configured yet.
      Package php5-cgi is not installed.
    
    dpkg: error processing squirrelmail (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of squirrelmail-locales:
     squirrelmail-locales depends on squirrelmail; however:
      Package squirrelmail is not configured yet.
    
    dpkg: error processing squirrelmail-locales (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of squirrelmail-viewashtml:
     squirrelmail-viewashtml depends on squirrelmail (>= 2:1.4.10); however:
      Package squirrelmail is not configured yet.
    
    dpkg: error processing squirrelmail-viewashtml (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of phpmyadmin:
     phpmyadmin depends on libapache2-mod-php5 | libapache2-mod-php5filter | php5-cgi | php5-fpm | php5; however:
      Package libapache2-mod-php5 is not configured yet.
      Package libapache2-mod-php5filter is not installed.
      Package php5-cgi is not installed.
      Package php5-fpm is not installed.
      Package php5 is not configured yet.
     phpmyadmin depends on php5-mysql | php5-mysqli | php5-mysqlnd; however:
      Package php5-mysql is not configured yet.
      Package php5-mysqli is not installed.
      Package php5-mysqlnd is not installed.
     phpmyadmin depends on php5-mcrypt; however:
      Package php5-mcrypt is not configured yet.
    
    dpkg: error processing phpmyadmin (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     php5-common
     php5-cli
     libapache2-mod-php5
     php5-curl
     php5-gd
     php5-imap
     php5-mcrypt
     php5-mysql
     php5
     postfix-cluebringer-webui
     php-apc
     squirrelmail
     squirrelmail-locales
     squirrelmail-viewashtml
     phpmyadmin
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    < ERROR > Installation failed, please check the terminal output.

  2. #2
    Just Joined!
    Join Date
    Jul 2014
    Posts
    30
    Please post the output from commands:
    Code:
    ls -la /bin/sh
    uname -a
    cat /etc/issue

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •