Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Lancashire, UK
    Posts
    25

    Struggling with a really basic problem - setting timeout on GRUB


    Hi there,
    I've just installed LinuxCNC for a hobby-project I'm undertaking.

    I've zero experience with Linux so this is me just looking at it for the first time. During the install I also installed GRUB as I want to be able to dual boot to my Windows install.

    The timeout is really fast so I want to slow it down (it's an age thing!).

    I Googled it and found the following code...
    Code:
    gksudo gedit /etc/default/grub
    I type this into my Terminal window (or into the window that pops up when I press Alt-F2) and get the prompt to enter my password - I enter my Linux password and then get the following error...

    Code:
    (gksudo:8257): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed
    This is literally my first ten minutes with Linux so please excuse my stupidity. Also, please do not assume any local knowledge in any answer you can give me. Words of one syllable or less much appreciated!

    Thanks

    John

  2. #2
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    1,704
    Use the system editor, nano or vim or whatever it might be. If you do not know what it is, following should work:
    Code:
    sudo $EDITOR /etc/default/grub

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Lancashire, UK
    Posts
    25
    Hi Segfault

    Thanks for your help. Unfortunately, I've tried entering that. The command prompt then asks for my password (which I type in but the cursor doesn't move?? I'm assuming that's normal?) then I get the following message...
    Code:
    sudo: /etc/default/grub: command not found
    Any ideas? Thanks again

  4. $spacer_open
    $spacer_close
  5. #4
    sudo nano /boot/grub/grub.cfg
    Inside this file there is entry called timout
    Modify the value as u like

    Sent from my SM-T231 using Tapatalk

  6. #5
    Just Joined!
    Join Date
    Feb 2005
    Location
    Lancashire, UK
    Posts
    25
    Thanks abdelaziz-saad, much appreciated!

    I actually had to write:
    Code:
    sudo nano /etc/default/grub
    to get to the correct file but your pointer to use "sudo nano" really did the trick.

    Thanks again for all your help

    ** EDIT ** Also worth noting a couple of other things just in case someone else finds this thread with the same problem.

    I changed "GRUB_TIMEOUT=10" to be the number of seconds I wanted to give myself before it chooses the default option to boot into.

    If you set this value to -1 you'll get infinite time to choose.

    Also, once you have made any changes, save them and run the following....
    Code:
    sudo update-grub
    Otherwise the changes won't come into effect.
    Last edited by johnnyt; 01-11-2017 at 04:30 PM. Reason: More info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •