Find the answer to your Linux question:
Results 1 to 8 of 8
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    MX-15: Internet (wifi) stops responding


    My wifi connection stops responding after a few minutes. The only solution i found so far is simply restarting the whole PC.

    I just realized i haven't tried turning the card power off/on yet. Gonna do that next time.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    14,038
    Interesting, but not enough information to help you.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    2,185
    How do you turn the card power off?

  4. $spacer_open
    $spacer_close
  5. #4
    iwconfig wlan0 power on/off

    no idea what it actually does, but it worked. its probably not the card, dont know what to call it.

  6. #5
    MX has inxi installed so if you run (in terminal) inxi -Fx it will display info on all your hardware. Post the output between code tags and folks can see what you have and maybe can help. Also, the MX forum is VERY helpful so a post there will get read. There are wifi cards with power down issues, I had one, so knowing what you have and what driver is loaded helps folks help you.. Here's what it will show:
    Code:
    System:    Host: tpd Kernel: 4.10.0-14-generic x86_64 (64 bit gcc: 5.4.0) Desktop: Xfce 4.12.3 (Gtk 2.24.28)
               Distro: Ubuntu 16.04 xenial
    Machine:   System: LENOVO (portable) product: 23252QU v: ThinkPad X230
               Mobo: LENOVO model: 23252QU Bios: LENOVO v: G2ETA5WW (2.65 ) date: 09/17/2015
    CPU:       Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10375
               clock speeds: max: 3300 MHz 1: 2615 MHz 2: 2689 MHz 3: 2619 MHz 4: 2605 MHz
    Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
               Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1366x768@60.02hz
               GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
    Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
               driver: snd_hda_intel bus-ID: 00:1b.0
               Sound: Advanced Linux Sound Architecture v: k4.10.0-14-generic
    Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e v: 3.2.6-k port: 6080 bus-ID: 00:19.0
               IF: enp0s25 state: down mac: 3c:97:0e:bc:81:4a
               Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi bus-ID: 03:00.0
               IF: wlp3s0 state: up mac: a4:4e:31:38:32:90
    Drives:    HDD Total Size: 480.1GB (19.4% used) ID-1: /dev/sda model: Micron_M500_MTFD size: 480.1GB
    Partition: ID-1: / size: 46G used: 8.0G (19%) fs: ext4 dev: /dev/sda3
    RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors:   System Temperatures: cpu: 52.0C mobo: N/A
               Fan Speeds (in rpm): cpu: 2973
    Info:      Processes: 172 Uptime: 14 min Memory: 449.3/7681.4MB Init: systemd runlevel: 5 Gcc sys: N/A
               Client: Shell (bash 4.3.461) inxi: 2.2.35
    Are you a clueless Kali user? If you can't get Kali running on your own, it ain't the right distro for you.

  7. #6
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    Quote Originally Posted by mindsword View Post
    iwconfig wlan0 power on/off

    no idea what it actually does, but it worked. its probably not the card, dont know what to call it.
    according to 'man iwconfig' it actually turns power management on/off.
    i suggest turning it off.
    or read the man page.

  8. #7
    the only solution i found that works without a complete reboot:

    GUI:
    • disable wifi on the xfce menu
    • disable networking on the xfce menu


    Code:
    sudo iwconfig wlan0 power off
    *wait a few seconds*

    Code:
    sudo iwconfig wlan0 power on
    GUI:
    • enable networking on the xfce menu
    • enable wifi on the xfce menu
    • reconnect to wireless network


    If i skip any of these steps it just doesnt work. Is there anything i can do to shorten this procedure? Its a little clumsy and annoying to have to disconnect for half a minute all the time...

    you said turning power management "off" permanently? ill try it.

    also is there a linux version of windows' "ipconfig release/renew"?

  9. #8
    -->
    Quote Originally Posted by mindsword View Post
    the only solution i found that works without a complete reboot:

    GUI:
    • disable wifi on the xfce menu
    • disable networking on the xfce menu


    Code:
    sudo iwconfig wlan0 power off
    *wait a few seconds*

    Code:
    sudo iwconfig wlan0 power on
    GUI:
    • enable networking on the xfce menu
    • enable wifi on the xfce menu
    • reconnect to wireless network


    If i skip any of these steps it just doesnt work. Is there anything i can do to shorten this procedure? Its a little clumsy and annoying to have to disconnect for half a minute all the time...

    you said turning power management "off" permanently? ill try it.

    also is there a linux version of windows' "ipconfig release/renew"?
    Keeping power management off didnt work. only the usual 8 step procedure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •