Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    image webcam upside down only on facebook messeger


    hello
    The issue concern the webcam on facebook messenger.
    image webcam upside down only with firefox and chromium.
    Mplayer and mpv the image is right
    Thanks for suggestion

  2. #2
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    1,779
    Probably Australian version of Facebook Messenger?

  3. #3
    lol, i had a similar acid remark.
    honestly, who cares about facebook, this cesspool of social emptiness...

    also, to give a slightly more technical answer:
    i doubt facebook messenger is open source so there really isn't much to do about it - since you say that it happens only there.
    How to ask smart questions | Don't be a Help Vampire
    You can post a link by removing "http://www." from it!

  4. $spacer_open
    $spacer_close
  5. #4
    Hi
    I'm here again. I got half solution about this issue..
    with firefox it is enough this: LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so firefox.
    But with chromium it doesn't work. It's look like chromium saw the webcam busy. The announcement:
    "Connect a camera and a microphone to make a call. If you are already connected, try restarting your browser and closing applications that use a camera or microphone."

    If I open chromium without that command the webcam is still upside down.
    Any suggest thanks a lot
    see you

  6. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    13,959
    Don't use Chromium? Some browsers let you adjust the aspect of the camera. I know that Skype does. I've never had Firefox capturing videos, assuming that is what you mean. I'm going to try your 1/2 solution to see if I can do that.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #6
    HI
    I mean:
    Firefox works with this command: LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so firefox. Without it the webcam is upside down.
    Chromium doesn't work with and without the same cammad.
    It looks like they don't have the permission to work with /dev/video0.
    thanks

  8. #7
    i always have several browsers installed.
    for certain tasks, i need to use a different browser.
    it's perfectly normal.
    How to ask smart questions | Don't be a Help Vampire
    You can post a link by removing "http://www." from it!

  9. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    13,959
    The nice thing about Linux is that you have so many options!
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  10. #9
    Hi there
    I've added "export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so" in etc/bash.bashrc.
    But i have to open firefox or chromium only from the terminal.
    If I open them from menu the webcam is upside down again.


    Thanks folks
    Here i don't feel alone

  11. #10

    re

    ...I did it also with $~/.bashrc without positive result.

    $ export -p | grep LD_PRELOAD
    declare -x LD_PRELOAD="/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so"

    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •