Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2018
    Location
    Italy, Bologna
    Posts
    11

    Talking disable graphical network interface


    Hi everyone, I have to configure a VLAN on my card. First I would like to disable the graphical network interface, how do I do it?

    thanks

  2. #2
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    Do you mean the Network Manager GUI?

  3. #3
    Just Joined!
    Join Date
    Mar 2018
    Location
    Italy, Bologna
    Posts
    11
    Quote Originally Posted by CarterCox View Post
    Do you mean the Network Manager GUI?
    YES , i want operate only in /etc/network/interface

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    Try
    Code:
    #systemctl disable NetworkManager.service
    And reboot.

  6. #5
    Just Joined!
    Join Date
    Mar 2018
    Location
    Italy, Bologna
    Posts
    11
    thank you so much


  7. #6
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    If you want to disable others, run
    Code:
    # systemctl --type=service
    Find the name and do the same thing as before.

  8. #7
    Just Joined!
    Join Date
    Mar 2018
    Location
    Italy, Bologna
    Posts
    11
    Hi Carter, how can I restart it? I try to /etc/init.d/network-manager restart
    but obviously, reboot and does not start

  9. #8
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    Once you have configured your network in /et/network/... run

    Code:
    #/etc/init.d/networking restart

  10. #9
    Just Joined!
    Join Date
    Mar 2018
    Location
    Italy, Bologna
    Posts
    11
    Sorry Carter but
    every time I restart the pc I lose the DNS configuration on resolv.conf. I reach the IP of the card but not the gateway

    My interface :
    auto lo
    iface lo inet loopback

    auto enp4s2.600
    iface enp4s2.600 inet static
    address xxx.xxx.xx.xx
    netmask 255.255.255.0
    gateway xxx.xxx.xx.xx
    vlan-raw-device enp4s2

    My network card is UP

  11. #10
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    -->
    Did you read the Debian guide for this? Did you disable other services as I told you before?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •