Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Debian stretch - upgrade messed up with firmware


    Hi team,

    Just performed a routine apt update & apt full-upgrade and after reboot (new kernel installed as well) I just got the error message, that Debian is missing firmware

    IMG_0286.JPG

    It is debian testing/buster on Lenovo Thinkpad X230. Does anyone enciunter similarvissues? I tried booting into the same kernel in recovery mode, but it does not work. First by going two kernel versions back i was able to boot and get into gnome.

    Thanks for suggestions!!



    Sent from my iPhone using Tapatalk

  2. #2

    Debian stretch - upgrade messed up with firmware

    Kernel versions available;

    4.16.0-1
    4.15.0-2
    4.14.0-3

  3. #3
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    we cannot see the image.
    you have made a narrative out of your problem, instead of giving us a technical description.
    we need to see all (relevant) commands entered and all output received.

    PS:
    why are you using testing if you cannot handle a little breakage after an upgrade?

  4. $spacer_open
    $spacer_close
  5. #4
    Quote Originally Posted by nihili View Post
    we cannot see the image.
    you have made a narrative out of your problem, instead of giving us a technical description.
    we need to see all (relevant) commands entered and all output received.

    PS:
    why are you using testing if you cannot handle a little breakage after an upgrade?
    Strange, the pic is not available anymore.

    basically the only thing I have done was apt update & apr full-upgrade, after a reboot I get stuck with a message stating:

    [] bluetooth hci0: firmware: failed to load bcrm/BCM30702A1-0a5c-21e6.hcd (-2)
    [] firmware_class: See wiki.debian.org/Firmware for information about missing firmware

    and then nothing happens afterwards, can just reboot and get back to GRUB with different kernelversions available.

    I shifted to testing because some of the tools I am using are newer, that was the rationale. Normally is hasn't been a problem like this.

    Does anyone encounter the same problem?

    Thanks.

  6. #5
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    Using unstable versions of Debian shouldn't be advisable for everyday use I guess. I'm not sure how unstable it is, but it shouldn't matter that much.

    If you need more bleeding edge software, why not use another distribution? Ubuntu or Mint would be a better idea if you want to stick with apt.

  7. #6
    Linux Engineer drl's Avatar
    Join Date
    Apr 2006
    Location
    Saint Paul, MN, USA / CentOS, Debian, Slackware, {Free, Open, Net}BSD, Solaris
    Posts
    1,472
    Hi.

    If I understand you correctly, you were running Debian stable, Stretch, and now you have a mixed system with testing, Buster. https://www.debian.org/releases/

    Although I have never tried it, running a mixed system can be catastrophic:
    How dangerous is it to run a mixed system?

    That depends on how many and what packages you are using, but it can be more dangerous than running pure unstable. Installing packages from different releases can cause complex problems which are less likely to occur with packages from a single release. One example is that existing packages may become uninstalled due to internal restructuring of central components within the testing or unstable branches.

    Try backports first. If you can't find what you need there you can also backport a package yourself.
    Noted at https://wiki.debian.org/FAQsFromDebi...ixed_system.3F

    You may be able to get more significant help from:
    Debian User Forums
    https://unix.stackexchange.com/
    but you need to be willing to do work yourself, neither one does hand-holding.

    Best wishes ... cheers, drl
    Welcome - get the most out of the forum by reading forum basics and guidelines: click here.
    90% of questions can be answered by using man pages, Quick Search, Advanced Search, Google search, Wikipedia.
    We look forward to helping you with the challenge of the other 10%.
    ( Mn, 2.6.n, AMD-64 3000+, ASUS A8V Deluxe, 1 GB, SATA + IDE, Matrox G400 AGP )

  8. #7
    Quote Originally Posted by nihili View Post
    we cannot see the image.
    you have made a narrative out of your problem, instead of giving us a technical description.
    we need to see all (relevant) commands entered and all output received.

    PS:
    why are you using testing if you cannot handle a little breakage after an upgrade?
    Dude you alway talk **** about others peoples tread if u don't want to Don't do it but treating people like they are an idiot suck it and swallow it

    Sent from my SAMSUNG-SM-G920AZ using Tapatalk

  9. #8
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    ^ Church!

    It's true though. Why use something that will require troubleshooting if you don't know how to troubleshoot, even if there are alternatives that don't require it?

  10. #9
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    Quote Originally Posted by user4711 View Post
    basically the only thing I have done was apt update & apr full-upgrade, after a reboot I get stuck with a message stating:

    [] bluetooth hci0: firmware: failed to load bcrm/BCM30702A1-0a5c-21e6.hcd (-2)
    [] firmware_class: See wiki.debian.org/Firmware for information about missing firmware

    and then nothing happens afterwards, can just reboot and get back to GRUB with different kernelversions available.
    i don't think the bluetooth firmware has anything to do with it.
    and it works with older kernel versions?
    you might be a victim of this.
    with what little information you gave, there isn't much more to say.
    can you switch to another tty with e.g. Ctrl-Alt-F2? text login, provide more information?
    until we get started with real troubleshooting, just continue using the older kernel versions.

    however, if you really are mixing sources (not sure i got that from your op), that's a big no-no on debian, and might have an impact on the situation.

    I shifted to testing because some of the tools I am using are newer, that was the rationale. Normally is hasn't been a problem like this.
    that's not a good rationale; testing is just what it says, it's for testing new software that might make it into debian proper.
    if you really need those newer versions (do you?), you might want to use a distro that is based on testing, but tries to minimize breakage. like ubuntu.

  11. #10
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    -->
    Quote Originally Posted by OMNI619 View Post
    Dude you alway talk **** about others peoples tread if u don't want to Don't do it but treating people like they are an idiot suck it and swallow it
    you just think that's how it is.
    it's just your perception, or to quote: That's just your opinion, man.

    fact remains:

    Quote Originally Posted by nihili
    we don't have crystal balls to look into, all we know about your situation is what you tell us about it
    i know it's a much discussed thing on online forums.
    doesn't make it less true.

    suck it and swallow it
    ouch, that's disgusting.
    but i don't mind the abuse; it really just shows what sort of person you are.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •