Find the answer to your Linux question:
Results 1 to 6 of 6
Hm. This is downright peculiar. Everything seemed to be going smoothly, just fine, until I logged my wife out this evening and logged myself in. I received a KDE error ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    15

    Sound disappeared.


    Hm. This is downright peculiar.

    Everything seemed to be going smoothly, just fine, until I logged my wife out this evening and logged myself in. I received a KDE error message:

    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.


    First time I've ever seen it.

    I tried reconfiguring sound in adminmenu (I'm using libranet upgraded to sarge) with no success; the test file doesn't even play.

    I noticed in boot up (figuring a reboot might "cure" the problem - I've been windows trained) that my sound thingy "i810" was listed as blacklisted. It's onboard sound with an intel 810 chipset in a tekram motherboard from a ways back - I can look it up if it becomes necessary.

    Huh, weird. I had installed ALSA after receiving the error message, thinking that might clear things up. It didn't, and nothing good came of it but a bunch of crap reminding me how old my system is and how ALSA doesn't support it, so I just tried apt-get remove alsa and it came up that nothing was found.

    Yet I just went through the alsa config a few minutes ago.

    HM.

    ust as suddenly, I have no sound mixers installed.

    I tried modconf, but installing the appropriate drivers there didn't seem to have an effect.

    Curioser and curioser.

  2. #2
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Which kernel are you using?

    As far as I'm concerned, I have always been a part of the "audio" group. If you run the ls -l /dev/dsp, I believe the group belongs to audio. I've been doing this ever since Debian 3.0r1.
    The best things in life are free.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    15
    I'm part of the audio group.

    I'm using kernel 2.4.21

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    15
    Hang on; I'm part of the audio group, sure, but what is the file we're bringing up information about?

  5. #5
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    /dev/dsp usually has the group audio. From what I've seen, as long as you belong in this group, it's OK.

    Can you try running XMMS (or any other sound applications) as root to narrow down this problem?
    The best things in life are free.

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Posts
    15
    I've been working on this in two forums; here and forum.libranet.com - I've posted more information there and have details about the current fix attempt I'm working on.

    http://forum.libranet.com/viewtopic.php?t=6993

    I'm posting this information because it seems that this problem creeps up on people all of a sudden and it would be nice for others to know if it is fixed or not.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •