Find the answer to your Linux question:
Results 1 to 2 of 2
I installed my HP 870C printer on Debian Sarge and it shows up under printers but it doesn't output anything unless I issue cat *.* >/dev/lp0 as root. Under properties ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2

    HP printer help - no output even thought it's listed


    I installed my HP 870C printer on Debian Sarge and it shows up under printers but it doesn't output anything unless I issue cat *.* >/dev/lp0 as root. Under properties it says the printer is ready but is not connected, will retry in 30 seconds. How can it be ready but not connected! In localhost:631, the Device URI is listed as: parallel:/dev/unknown-parallel0. Obviously this isn't going to work. On a working system it's listed as /dev/lp0. Can anyone help me get this corrected? Thanks.

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2
    OK, I fixed it. Apparently the cups daemon was not started when I set it up the first time. I issued command cupsys restart as root and then ran localhost:631, everything worked fine after that. Linux can sure make you feel dumb sometimes...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •