Find the answer to your Linux question:
Results 1 to 8 of 8
hello i have installed after i have used Fedora and Xandros now debian 30 r 4 i have installed debain in ok and all working infact not mine mouse. when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    9

    mouse doesn't work


    hello i have installed after i have used Fedora and Xandros now debian 30 r 4

    i have installed debain in ok and all working infact not mine mouse.
    when i login in GDM as normal user the mouse not work

    mine mouse = PS/2 Logitech with scrollwheel

    when i make CTRL - Alt - F1
    i came back and i log in as Root
    then i see when i make LS -L

    -XF86Config
    -XF86Config.new

    i start -XF86Config

    i choise for -4 PS/2 mouse
    then y for 3 mousebuttons

    device = dev/mouse


    i also have try as device = dev/psaux

    but this also not work
    what can i do or make to let mine mouse work in debian

    thank you

  2. #2
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    When you're done running XF86Config, you should move the temporary file that you save your configuration to /etc/X11/XF86Config or /etc/X11/XF86Config-4.

    for example:
    Code:
    cp XF86Config.new /etc/X11/XF86Config

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    9
    i try also this but also not work

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie eerok's Avatar
    Join Date
    Feb 2005
    Location
    Canada
    Posts
    153
    I'm also having problems getting my logitech mouse working in debian -- though I'm using sarge. One or both of these command lines should produce a reaction from mouse movement if the device is working (it will actually corrupt your keymap until you reboot):

    Code:
    cat /dev/psaux
    cat /dev/input/mice
    However, I get nothing.

    My thinking is that it's time to config/compile a kernel ...

  6. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    My Logitech scroll mouse works great in Fedora Core 1 and 3. Optical type with usb plug, but connected with a ps/2 adapter. xorg.conf excerpt follows (same for XF86Config):
    Code:
    Section "InputDevice"
            Identifier  "Mouse0"
            Driver      "mouse"
            Option      "Protocol" "IMPS/2"
            Option      "Device" "/dev/psaux"  # some versions use "/dev/input/mice": check yours.
            Option      "ZAxisMapping" "4 5"
            Option      "Emulate3Buttons" "no"
    EndSection
    I hope that helps.
    /IMHO
    //got nothin'
    ///this use to look better

  7. #6
    Linux Newbie eerok's Avatar
    Join Date
    Feb 2005
    Location
    Canada
    Posts
    153
    Quote Originally Posted by drakebasher
    Optical type with usb plug, but connected with a ps/2 adapter.
    Mine is exactly the same, except it also goes through a kvm switch. It's my favorite mouse of all time, and it runs great under all the linuxes and bsd's I've tried, with both devfs and udev.

    Anyway, it turned out my suspicion was correct, and a custom kernel fixed my problem.

    So this is my first post anywhere under debian sarge
    noobus in perpetuum

  8. #7
    Just Joined!
    Join Date
    Sep 2005
    Posts
    6

    Logitech USB Optical freezes in Games in Xandros

    When I play some games my Mouse freezes in the game, but works fine without playing games and just using normally on the desktops.

    1. Logitech MX500 USB Optical
    2. Xandros 3.0 Deluxe w/ 2.6.11-smp kernel

    /etc/X11/xorg.conf:

    ################################################## ##############################
    ## Automatically generated file by buildxconf
    ## part of the Xandros hardware detection system
    ##
    ## See Also:
    ## 'man devices-overview' for information about the detection system
    ## 'man setxconf' a utility for interacting with the detection system
    ## to modify the X configuration
    ## 'man xorg.conf' for the format of this file
    ##
    ## Warning:
    ## If this file is edited manually, then buildxconf will no longer
    ## modify this file. It must be removed to be regenerated.
    ################################################## ##############################


    Section "Files"
    ModulePath "/usr/X11R6/lib/modules/nvidia"
    ModulePath "/usr/X11R6/lib/modules/altdrivers"
    ModulePath "/usr/X11R6/lib/modules"

    # Local Fontserver: Disabled by default.
    #FontPath "unix/:7100"

    # Unscaled Bitmap Fonts:
    FontPath "/usr/lib/X11/fonts/75dpi:unscaled"
    FontPath "/usr/lib/X11/fonts/100dpi:unscaled"
    # Scalable TrueType and CID Fonts (via DeFoMa):
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

    # Scalable TrueType Fonts (via std X path):
    FontPath "/usr/lib/X11/fonts/TrueType"

    # Scalable Speedo and Type1 Fonts:
    FontPath "/usr/lib/X11/fonts/Type1"
    FontPath "/usr/lib/X11/fonts/Speedo"

    # Scaled Bitmap fonts (ugly) :
    FontPath "/usr/lib/X11/fonts/75dpi"
    FontPath "/usr/lib/X11/fonts/100dpi"
    FontPath "/usr/lib/X11/fonts/misc"
    FontPath "/usr/lib/X11/fonts/cyrillic"

    # Misc. Fonts:
    FontPath "/usr/share/fonts"
    EndSection

    Section "Module"
    Load "ddc"
    Load "int10"
    Load "xandetect"
    Load "dbe"
    Load "extmod"
    Load "glx"
    Load "record"
    Load "bitmap"
    Load "freetype"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    EndSection

    Section "InputDevice"
    Identifier "mouse.usb"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "IMPS/2"
    Option "Emulate3Buttons" "YES"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    # pci info: 0x10de, 0x0041, 0x0000, 0x0000
    Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    Option "NoRenderAccel"
    Option "VideoRam" "124928k"
    BusID "PCI:1:0:0"
    Screen 0
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "DEL"
    ModelName "DELL M993s"
    HorizSync 30-96
    Option "DPMS"
    EndSection

    # res 1280 1024
    Section "Screen"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    SubSection "Display"
    Depth 4
    Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "ServerFlags"
    AllowMouseOpenFail
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Screen1"
    InputDevice "Keyboard1"
    InputDevice "mouse.usb"
    EndSection

  9. #8
    Linux User
    Join Date
    Apr 2005
    Location
    Ohio
    Posts
    326
    Check that the necessary modules are loaded..

    Modules that affect the mouse are as follows

    mousedev
    psmouse
    input
    hid - for USB mice


    lsmod to list loaded modules. ( or lsmod | grep mouse ) if you don't see one of the modules I listed try modprobing it..

    modprobe mousedev
    then start/restart X (in my case with mousedev missing X wouldn't even start.. )

    test your mouse again.. repeat with any other missing modules until you find which one you need..

    If you find it is a missing modules that is causing the problem add it to /etc/modules so it will load automatically when you start your system.
    far...out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •