Find the answer to your Linux question:
Results 1 to 7 of 7
Hey, ok first off i am trying to use Debian, i got it installed fine, i went to http://www.debian.org/devel/debian-installer/ and downloaded the i386 netinstall version and ran that, i went ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    major debian help needed asap


    Hey, ok first off i am trying to use Debian, i got it installed fine, i went to http://www.debian.org/devel/debian-installer/ and downloaded the i386 netinstall version and ran that, i went through and set up the xf86config file according to my system, but found out ppl with nvidia cards were having problems, which when i would try to startx id get (EE) no devices detected, i tried everything using my specific card "geforce fx 5600" but still got the same thing, i went and used the vesa vesa in xf86cfg gui setup, well after i saved the changes my screen went black and wont do anything, i have to shutdown and restart to get back to login screen, but i still have the errors about no devices detected, please help me, you can reach me on aol im or msn messenger.

    p4 2.4ghz
    512ddr
    KDS Rad5 LCD Monitor
    GeForce FX 5600 256DDR

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Location
    UK
    Posts
    37
    What version/release of Debian is it you're installing?

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Location
    Toronto, Canada
    Posts
    7

    get an update of xfree86

    The version of xfree86 with debian is old. it does not recognise many of the newer graphic cards. get the latest xfree86 and install it using Xinstall, then it will be fine

  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    65
    Hello,
    I id a search and ran acrost this post. I have the new Debian 3.1 and get the exact same problem. Do I need to download a seprate Xfree86?
    Thanks...

  5. #5
    Linux User St. Joe's Avatar
    Join Date
    Jun 2005
    Location
    USA
    Posts
    271
    Try the most universal setting for your vid card.
    Run the command below as root and select 'nv' for the gfx driver.
    Code:
    # dpkg-reconfigure xserver-xfree86

  6. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    80
    Try this to install the official nvidia driver, which you can download from nvidia.com.

    $ uname -r (gives you kernel version)
    $ su
    # apt-get install kernel-source-whatever
    # apt-get install kernel-headers-whatever

    then

    $ /etc/init.d/gdm stop (or kdm if you use kde)

    $ su
    # sh NVIDIA.blah.blah.blah( install nvidia driver)

    # nano /etc/X11/XF86Config-4

    edit the line "Section" Device"
    comrnt out (# in front of) GLcore and dri
    -change "nv" to "nvidia"
    -save and exit

    # modprobe nvidia
    # exit
    $ startx

    If all went well you should see a nvidia splash screen before the log in.

  7. #7
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    There's something else you might want to check also, make sure that your mouse is also correctly configured, x will not start without it.

    I went crazy once thinking that my graphic card was the problem but in the end it was the mouse !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •