Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
so i got the repositories for the sourcelist, then i went to my synapic pakcage manager and download fluxbox and everything that needed to be downloaded along with it. and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jul 2005
    Location
    massachusetts, north america
    Posts
    105

    fluxbox


    so i got the repositories for the sourcelist, then i went to my synapic pakcage manager and download fluxbox and everything that needed to be downloaded along with it. and i don't see it anywhere.

    what i've done.

    in terminal:
    fluxbox
    open fluxbox
    fluxbox open
    fluxbox shell
    shell fluxbox

    in my "run" thing:
    fluxbox

    i also restarted my computer, but still nothing. i use ubuntu 5.04
    Signature removed by moderator - please see forum rules or else.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    go to /home/.xinitrc and enter: exec fluxbox

    save the file and when you login next, X should open in fluxbox

  3. #3
    Linux Newbie
    Join Date
    Jul 2005
    Location
    massachusetts, north america
    Posts
    105
    Quote Originally Posted by Ozar
    go to /home/.xinitrc and enter: exec fluxbox

    save the file and when you login next, X should open in fluxbox
    " /home/.xinitrc " as in my home folder?, if so there's nothing fluxbox related there, and when i put it in terminal it just tells me directory can't be found, yeah, i know i'm doing some **** wrong with something simple.
    Signature removed by moderator - please see forum rules or else.

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    When I posted that, I was thinking you might not be running any other window manager. If you are running Gnome, with GDM, you should be able to log out, then when you get ready to log back in, look at the "sessions" option, and pick Fluxbox. I don't run gdm, so I'm not certain that it will be there as an option.

  6. #5
    Linux Newbie
    Join Date
    Jul 2005
    Location
    massachusetts, north america
    Posts
    105
    eh, i'm not running any other windows manager, i don't think, the most alterating thing i installed to my desktop is gdesklets
    Signature removed by moderator - please see forum rules or else.

  7. #6
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Ok, if no other WMs, I'm assuming you are using xdm as your display manager and that you've successfully installed and configured your machine to start an X display.

    You should be able to create the .xinitrc file in your /home directory using vim, nano, pico, or some other text editor. Note the dot in front of the file name.

    Insert the line: exec fluxbox

    save the file

    enter the command: startx

    This should start fluxbox.

  8. #7
    Linux Newbie
    Join Date
    Jul 2005
    Location
    massachusetts, north america
    Posts
    105
    so i went to my text editor and created a file named "xinitrc" with nothing in it, then went to terminal and put exec fluxbox and then startx, still nothing

    Code:
    Failed to read: session.useMod1
    Setting default value
    apps file failure
    ThemeItem<Font>&#58; Warning! Failed to load default value 'fixed'
    ThemeItem<Font>&#58; Warning! Failed to load default value 'fixed'
    ThemeItem<Font>&#58; Warning! Failed to load default value 'fixed'
    Failed to read&#58; session.screen0.imageDither
    Setting default value
    Failed to read&#58; session.screen0.opaqueMove
    Setting default value
    Failed to read&#58; session.screen0.sloppywindowgrouping
    Setting default value
    Failed to read&#58; session.screen0.workspacewarping
    Setting default value
    Failed to read&#58; session.screen0.desktopwheeling
    Setting default value
    Failed to read&#58; session.screen0.autoRaise
    Setting default value
    Failed to read&#58; session.screen0.clickRaises
    Setting default value
    Failed to read&#58; session.screen0.decorateTransient
    Setting default value
    Failed to read&#58; session.screen0.rootCommand
    Setting default value
    Failed to read&#58; session.screen0.resizeMode
    Setting default value
    Failed to read&#58; session.screen0.windowMenu
    Setting default value
    Failed to read&#58; session.screen0.followModel
    Setting default value
    Failed to read&#58; session.screen0.window.focus.alpha
    Setting default value
    Failed to read&#58; session.screen0.window.unfocus.alpha
    Setting default value
    Failed to read&#58; session.screen0.menu.alpha
    Setting default value
    Failed to read&#58; session.screen0.menuDelay
    Setting default value
    Failed to read&#58; session.screen0.menuDelayClose
    Setting default value
    Failed to read&#58; session.screen0.menuMode
    Setting default value
    Failed to read&#58; session.screen0.overlay.lineWidth
    Setting default value
    Failed to read&#58; session.screen0.overlay.lineStyle
    Setting default value
    Failed to read&#58; session.screen0.overlay.joinStyle
    Setting default value
    Failed to read&#58; session.screen0.overlay.capStyle
    Setting default value
    BScreen&#58;&#58;BScreen&#58; an error occured while querying the X server.
            another window manager already running on display &#58;0.0
    root@max&#58;/home/maxcespedes # startx
    
    Fatal server error&#58;
    Server is already active for display 0
            If this server is no longer running, remove /tmp/.X0-lock
            and start again.
    
    
    Please consult the The X.Org Foundation support
             at http&#58;//wiki.X.Org
     for help.
    Signature removed by moderator - please see forum rules or else.

  9. #8
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    i went to my text editor and created a file named "xinitrc"
    Note that the file needs a dot in front of it, like this: .xinitrc

    I'm not sure how far along you are in your install.

    Did you do a fresh netinstall of Debian Sarge?

    Did you install the X system after completing the base install?

    Did you run xf86config?

    What other apps have you installed?

  10. #9
    Linux Newbie
    Join Date
    Jul 2005
    Location
    massachusetts, north america
    Posts
    105
    Quote Originally Posted by Ozar
    i went to my text editor and created a file named "xinitrc"
    Note that the file needs a dot in front of it, like this: .xinitrc

    I'm not sure how far along you are in your install.

    Did you do a fresh netinstall of Debian Sarge?

    Did you install the X system after completing the base install?

    Did you run xf86config?

    What other apps have you installed?
    i use ubuntu 5.04
    i edited out my sourcelist with the one ubuntuguide said i should have
    i got fluxbox from synapic
    that's it.
    and putting ".xinitrc" didn't help
    Signature removed by moderator - please see forum rules or else.

  11. #10
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Ok, I think Ubuntu uses GDM, so you should be able to select a fluxbox "session" in GDM right before logging in. You can delete the .xinitrc file if it's not needed.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •