Find the answer to your Linux question:
Results 1 to 7 of 7
Guys, I can't seem to get my mouse working in Ubuntu. I already posted a message on the Ubuntu forums but I still can't get any replies or help concerning ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Location
    Baguio City, Philippines
    Posts
    2

    Ubuntu 5.04 2.6.20 kernel, PS/2 mouse not working. Already did basic configurations.


    Guys, I can't seem to get my mouse working in Ubuntu. I already posted a message on the Ubuntu forums but I still can't get any replies or help concerning my PS/2 Genius NetScroll mouse to work with Ubuntu 5.04. I've been googling on this issue for so long that I even found an article regarding Linux Torvalds having some issue with mouse. Although he found a workaround, I still can't. I've ran out of options and quite desperate. I've also spent a lot of time reading those man pages for grub & xorg.conf but still no luck. Here's what I posted in the Ubuntu forums:
    --------------
    Hi guys. I'm having a problem here. I'm not sure if it's X, ps/2 mouse, or even grub.

    After 3 hours of installing Ubuntu, I found out that the mouse doesn't work from the login to the desktop. I tried googling about this problem and found some solutions, tried all of them but didn't work.

    From the desktop, which seems frozen, I did "Ctrl+Alt+F1" went to the command line, edited /etc/modules but I cant startx. So I reboot, logged in, mouse still not working, then "Ctrl+Alt+Backspace" from desktop, configured some files again and again until all the solutions I found has been exhausted. Anyway, here's what I did.

    1. made sure "mousedev" & "psmouse" properly listed in "etc/modules"

    2. "/var/log/Xorg.0.log" indicates no errors or failures

    3. changed "psmouse" to "psmouse proto=exps" & "psmouse.proto=imps" in "/etc/modules"

    4. for "/etc/X11/xorg.conf":

    a. changed "Protocol" from "ImPS/2" to "PS/2" & "Auto"

    b. changed "Device" from "/dev/input/mice" to "/dev/psaux" & "/dev/input/mouse0"

    Unfortunately, none worked. Frustrated, I boot up the Vector Linux 4.3 CD and saw that I could boot up a linux partition from there. So at the prompt I typed in "linux root=/dev/hda3 ro" got into the Ubuntu login screen and to my surprise, my mouse started to work. I logged in just to check that my eyes aren't deceiving me. Lo & behold, everything is working like it should be. For the first time, I got to enjoy Ubuntu. My logic told me that the 2.6.10 kernel of Ubuntu isn't working properly with my machine. Vector has 2.4 kernel.

    More determined than ever to find out the real cause of this problem, I booted up in recovery mode and tried scanning for any errors & failures, especially those referring to my mouse. The only error I got is when the machine is trying to sync the system clock. Then I found something. After 3 reboots, I got to list down this:

    mice: PS/2 Mouse device common for all mice
    input: ImPS/2 Generic Wheel Mouse on ISA0060/seria01

    Is it possible that Ubuntu has setup my mouse on the ISA bus instead of the PS/2. How do I fix this? Do I need to edit some file? I tried locating the grub.conf, maybe I could start from there but I just can't locate it. Can anyone help me out here? I've been working on this computer for 16hours now and I'm a bit depressed, frustrated, & tired especially since I wanted to work with Ubuntu. Any help is deeply appreciated.


    Hardware: P3 733Mhz, 384MB SDRAM, 64MB for onboard Video. Asus Motherboard, Sis630. 20GB Seagate HDD. hda3=/ (2GB)ReiserFS, hda5=/home (2GB)ReiserFS, hda6=swap (1GB).Lite-On CD-RW.

    ***Updates: 26July2005 0305H***

    Errata: Vector 4.3 uses the 2.6.7 kernel. Either way, would this help me with my problem?

    I finally got to edit Grub, it's not /etc/grub.conf but /boot/grub/menu.lst, but one thing I really need to know, does the "initrd /boot/initrd.img-2.6.10-5-386" contain a line or something that points to my mouse, if so, is it safe to edit? If not, are there any other files that loads at boot up that I might need to take a look at?

    I tried copying the vmlinuz-2.6.7-ide4 of Vector to Ubuntu and changed the line in Grub to 'kernel /boot/vmlinuz-2.6.7-ide4 ro' and as expected, it didn't work. Well at least I'm not giving up on fixing this problem.

    When I tried booting up Ubuntu using the Vector CD, I noticed that some lines had "fail" in them. I really can't see it well and can't pause it. But from what I know, it failed to load something in '/lib/...'

    If only someone with a kind heart tell me what file I need to edit that loads this thing, then maybe, just maybe, I'll be very happy with Ubuntu. It doesn't matter if it crashes the whole system and need to reinstall Ubuntu, I am after all, still learning Linux, and one great way of learning real quick is if you do a lot reinstalling, trial & error, and even configuring & rebooting. And everytime I mess something up, I learn something new.

    I will still try configuring Ubuntu, but it will save me a lot of time if someone with expertise in Ubuntu & Linux in general would give me a few pointers.

    I also tried googling regarding this issue, none seems to work. I must say, I have a very unique issue. Imagine, a ps/2 mouse not working in Linux... Ha!

    I also like to thank you for spending some time reading this.
    --------------------------

    I'm also not sure about this, but if only I could access or even know what file it uses to initialize bootup or commands, then maybe I could tweak it and get my mouse working. So if anyone knows what file I need to check on, please inform me. I'm really quite desperate & frustrated. I've been working on this for about a week now with no success and I haven't have time for anything else but this. Please help me.

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    the first thing I would try is
    Code:
    apt-get install mdetect
    then run
    Code:
    mdetect
    to see if it can locate the mouse
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    May 2005
    Location
    Baguio City, Philippines
    Posts
    2
    tried that, still no luck. any more ideas? I'm really tired of having to boot up ubuntu using the vector linux cd. but thanks anyway vergil83 for the suggestion.

  4. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    Quote Originally Posted by daxumaming
    tried that, still no luck. any more ideas? I'm really tired of having to boot up ubuntu using the vector linux cd. but thanks anyway vergil83 for the suggestion.
    did mdetect not find anything?

    I really don't see much you could be missing..... this is my old ps/2 mouse config (in debina xfree not xorg)
    Code:
    Section "InputDevice"
            Identifier      "Configured Mouse"
            Driver          "mouse"
            Option          "CorePointer"
            Option          "Device"                "/dev/psaux"
            Option          "Protocol"              "PS/2"
            Option          "Emulate3Buttons"       "true"
            Option          "ZAxisMapping"          "4 5"
    EndSection
    do you have the "corepointer" option ?
    Brilliant Mediocrity - Making Failure Look Good

  5. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    PS2 Keyboard and mouse in Ubuntu 6.10

    I had the problem that even attempting to run/install from the LiveCD, my PS2 keyboard AND my PS2 mouse were dead. I went into BIOS settings and turned OFF (disable) USB Mouse and USB Keyboard. Now everything works fine.

  6. #6
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2
    My USB mouse quit working after kernel 2.6.20 also. It turned out that my mouse had moved from /dev/input/mouse2 to /dev/input/mouse3.

    This is pathetic but here's how I figured it out:

    I logged in as root and tried

    cat /dev/input/mouse0
    cat /dev/input/mouse1
    cat /dev/input/mouse2
    cat /dev/input/mouse3

    I wiggled the mouse each time to see which one spat out data to identify which device file was tied to my mouse.

    I then edited my xorg.conf file and in the InputDevice section I changed
    Option "Device" "/dev/input/mouse2"
    to
    Option "Device" "/dev/input/mouse3"

    The next time I started X, it was all better.

  7. #7
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3

    How to fix your problem

    UPGRADE TO UBUNTU 7.10 its better!!!!!!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •