Find the answer to your Linux question:
Results 1 to 6 of 6
I am currently running Sarge on a 2.5 ghz celeron processor. I use an external modem and have used pppconfigure to get the connection to dial out which it does. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    5

    trouble with dial up connection


    I am currently running Sarge on a 2.5 ghz celeron processor. I use an external modem and have used pppconfigure to get the connection to dial out which it does. The problem that I am having is that when eth0 is up the connection will not let me dial out and connect. I have to disable eth0 to get the internet. Anyone know of anything I might be missing in order to get both to work at the same time? I know that I have done similar things with fedora core 4 and suse 9.2 and have had no problems. I really like debian and do not want to have to go to another distro to solve this issue.

    Thanks

  2. #2
    Just Joined!
    Join Date
    Jul 2005
    Posts
    19

    Tried kppp

    I would hate to see you abandon debian because you can't get pppconfig to work.
    Considered using kppp for dialout?
    Regards

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    5
    tried kppp gppp and others...the problem does not appear to be with dialing it seems to be with routing. I can get the connection to connect but whenever it is connected my system does not want to allow the dialup connection to become the default route. It wants the ethernet to take control at all times.

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Location
    Topeka, KS, USA
    Posts
    88
    That's probably why my kppp doesn't work, because I haven't killed sl0. I'll have to try that.

    Back to your question tudawggz, do you need the ethernet up? I figure you must be using it to connect to a local network while you actually use the modem for internet communications. As soon as you have difficulty with two connections on the same computer, it sounds like a routing issue. That would mean that the computer is confused about where traffic needs to be directed. I'd hazard a guess that your default route is set to the ethernet connection rather instead of the modem, when you'd really want it the other way around. This is assuming that Linux networking controls traffic the same way as Windows, which I'm more familiar with.

    Take a look at http://linux-ip.net/html/routing-intro.html and http://www.linux.com/guides/nag2/x-0....routing.shtml and follow them through to other pages to find out how to gain more control of your networking. I'm going to have to try this myself to see if I can get mine working.

  5. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    5
    I may have found my answer at
    http://www.aboutdebian.com/modems.htm
    I may need to set default route by
    route add default ppp0
    I will try and note it once I have tried it.

  6. #6
    Just Joined!
    Join Date
    Jul 2005
    Posts
    5
    UPDATE

    Adding the ppp0 connection as default actually worked. Just in case others are having similar problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •