I have been trying the Debian Sarge Distribution( Kernel 2.6. on two Single Board Computers. One has PS/2 port and the mouse is attached to it. I get no problems getting my Debian system running on these boards.

While the other board does not have any PS/2 port so the mouse is attached to USB port. After my installation is finished, when the Debian boots, I get kernel error message:

psmouse.c: bad data from KBC - time out bad parity.

I know that my Linux boots to the login prompt but the rate at which this message is thrown on my screen is so fast that I can't type anything. Everything loads fine except I get these messages continuously and at a very fast rate. It just freaks out.


I googled about this error message and it seems that there is some kind of bug in the kernel and people have suggested to manually change the kernel source such as in this website:
http://klingon.uab.es/gali/presario.html to stop those error messages.

I am really not comfortable with modifying the kernel source and I have never done this before. Is there any other way by which I can achieve this? Does anyone know a patch for this which I can download and patched to my existing kernel?

Also, does anyone know a kernel parameter which we can give at the boot-time to disable all the PS/2 stuff.

Any help will be greatly appreciated.