Find the answer to your Linux question:
Results 1 to 7 of 7
Hello. How do you log in as root? Because i have only created one user, as far as i recall, called "mig" and a password for that too. I haven't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    43

    How do you log in as "root"?


    Hello. How do you log in as root? Because i have only created one user, as far as i recall, called "mig" and a password for that too. I haven't made an root-user, i think. But at the graphical KDE 3.3 login-menu in the start, i tried typing root insted of mig, and then my password i use to my user mig. It just says "root logins not allowed" Now what should i do? And how do i edit my root-password?

  2. #2
    Linux Newbie
    Join Date
    Apr 2005
    Location
    The Slammer
    Posts
    137
    I suppose you're using Ubuntu?
    Just type sudo passwd at the command line and supply a new root password to enable the account.

    BTW, you can always carry out all the administrative tasks via the sudo command. No need for the root account.
    Registered Linux User #394578

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    43
    Thank you, but no, i am using the Debian Net-installer-CD, that weighted around 180 mb, from www.debian.org. Is it still the same i should write? Because then i type "passwd", it just changes my normal user, mig, pass. And then i type sudo, it just says "bash: sudo: command not found"

  4. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    43
    25 looks, and so little answers? Please help me, guys...

  5. #5
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    To use sudo you'll have to install the 'sudo' -package with apt-get or if you prefer another way you can use that. Then you pobably have to edit your /etc/sudo file to be able to use sudo.

    You can not login as root in grahpical because of security reasons. If you need to issue commands as root without installing the 'sudo' -package you can run:
    Code:
    # su -
    [password]
    When you run 'su -' you'll be asked to enter the root password.

  6. #6
    Just Joined!
    Join Date
    Aug 2005
    Posts
    43
    Thank you alot, it's working now. And i found http://www.linuxforums.org/tutorials...ial-19957.html
    and followed it. Weeeeeeeeee

  7. #7
    Just Joined!
    Join Date
    Sep 2005
    Location
    East Coast
    Posts
    4
    You can also change the preferences of the login manager to allow root logins. Gave me trouble in the begining.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •