Find the answer to your Linux question:
Results 1 to 8 of 8
Hello, I'm a newbe in linux and I can't resolve cdrom mounting issue. Think I broke it ( #mount /cdrom mount: /dev/scd0 is not a valid block device #mount /media/cdrom1 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4

    Help ! I broke my CDROM device support


    Hello, I'm a newbe in linux and I can't resolve cdrom mounting issue. Think I broke it (

    #mount /cdrom
    mount: /dev/scd0 is not a valid block device

    #mount /media/cdrom1
    mount: No medium found

    # cat /etc/fstab | grep cdrom
    /dev/hdc /media/cdrom1 iso9660 ro,user,noauto 0 0
    /dev/scd0 /media/cdrom0 iso9660 ro,user,noauto 0 0

    # ls -la /dev/cdrom
    ls: /dev/cdrom: No such file or directory

    # dmesg | grep hdc
    ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdcMA, hddio
    hdc: QSI CD-RW/DVD-ROM SBW-241, ATAPI CD/DVD-ROM drive
    hdc: attached ide-cdrom driver.
    hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)

    #dmesg | grep scd0 - USB CDROM is not recognized at boot-up

    Before I could always mount both of my CDROM's (internal and extrernal USB ).
    Then I started messing with fstab (although I've set everything back as it was before)I could never mount
    them again.

    Any idea as to why I cant mount them anymore? WHERE COULD I MESS IT UP ? And can I restore the system without having to reinstall it opnew ?

    Thnk you very much.

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    I assumed you have tried different cdrom (ie audio cds are not mounted).

    You might took at dmesg and see if there are any errros on startup
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Topeka, KS, USA
    Posts
    88
    Have you tried turning
    /dev/hdc /media/cdrom1 iso9660 ro,user,noauto 0 0
    into
    /dev/hdc0 /media/cdrom1 iso9660 ro,user,noauto 0 0

    And that first command you attempted, try instead
    mount /media/cdrom0
    or
    mount /dev/scd0

    And as Virgil pointed out, make sure you have valid data (not voice) media mounted in the device when you attempt this, and if one disk fails, try some others.

    In the future, it might be a good idea to copy the file to another name before modifying it, then you can just delete the bad file and copy the backup back should the need arise.

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Location
    Topeka, KS, USA
    Posts
    88
    Keep your replies in the thread so others can participate thom.

    message recieved:

    Hello, thank you for reply.

    I cannot mount any - data or audio CD. Whien I try to do it
    wia KDE, like CDPlayer, it says - drive error. And when I try
    to change fstab line as you advised :/dev/hdc /media/cdrom1 iso9660 ro,user,noauto 0 0 into /dev/hdc0 /media/cdrom1 iso9660 ro,user,noauto 0 0 , I get the same result, only this time:

    mount: special device /dev/hdc0 does not exist

    Other similar manipulations produce the same:

    debian:/home/debian# mount /media/cdrom0
    mount: /dev/scd0 is not a block device

    debian:/home/debian# mount /dev/scd0
    mount: /dev/scd0 is not a block device

    debian:/home/debian# mount /dev/scd0
    mount: /dev/scd0 is not a block device

    debian:/home/debian# mount /dev/scd0
    mount: /dev/scd0 is not a block device

    debian:/home/debian# mount /media/cdrom1
    mount: special device /dev/hdc0 does not exist

    dmesg does not seem to show any errors. The only relevant part of it
    referreing to CDROM :
    debian:/home/debian# dmesg | grep hdc
    ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdc:DMA, hdd:pio
    hdc: QSI CD-RW/DVD-ROM SBW-241, ATAPI CD/DVD-ROM drive
    hdc: attached ide-cdrom driver.
    hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33).
    Thats all Sad
    Btw, I'm using 2,4 kernel. Could it be something that I need to upgrade, or so.
    Please, forgive my ignorance but how does Linux talk to CDROM's - only via fstab,
    or there might be more configuration files ?

    Will appreciate further idea's

    Thom

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Location
    Topeka, KS, USA
    Posts
    88
    Are you sure the external device is scd? It should be one of sda0, sdb0, sdc0. That would be why you're getting the block error on your attempt to mount the usb drive.

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Location
    Topeka, KS, USA
    Posts
    88
    Hmm, I'm not at my machine, but it looks like with cdrom devices, you don't need the number after the device (I forget that since there is only one file system possible on a cd, so you probably need the /dev/hdc the way you had it originally, and use sda, sdb, sdc, or sdd (whichever one works) for the external.

    You should probably try to use the mount command with options instead of editing the fstab file all the time. Once you have the mount command down, then you can update the changes to the fstab. The mount command would look the same as your fstab line, but with mount in front of it. For instance, if
    Code:
    mount /dev/sdc /media/cdrom0
    works, then you can know that it's OK to make those changes to the fstab.

  7. #7
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4
    Quote Originally Posted by ericrun
    Are you sure the external device is scd? It should be one of sda0, sdb0, sdc0. That would be why you're getting the block error on your attempt to mount the usb drive.
    Right now, I only want to mount internal CDROM and no matter how I call it in mount command ( it was always hdc before) I get at best mount usage help screen

    I even thought there was something with kernel, so I upgraded to 2,6 - no difference- it's either : the special device does not exist, or not a valid block device

    Looks like this is not a newbe problem. I'm clueless. Thinking of good old windows cure - reinsrall

  8. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4
    Quote Originally Posted by thom10
    Quote Originally Posted by ericrun
    Are you sure the external device is scd? It should be one of sda0, sdb0, sdc0. That would be why you're getting the block error on your attempt to mount the usb drive.
    Right now, I only want to mount internal CDROM and no matter how I call it in mount command ( it was always hdc before) I get at best mount usage help screen

    I even thought there was something with kernel, so I upgraded to 2,6 - no difference- it's either : the special device does not exist, or not a valid block device

    Looks like this is not a newbe problem. I'm clueless. Thinking of good old windows cure - reinsrall
    One more thing. This may be interestng. When I ran <cdrecord -scanbus>
    this is what I get :

    cdrecord: Warning: Running on Linux-2.6.8-2-386
    cdrecord: There are unsettled issues with Linux-2.5 and newer.
    cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
    cdrecord: Warning: Linux-2.6.8 introduced incompatible interface changes.
    cdrecord: Warning: SCSI transport does no longer work for suid root programs.
    cdrecord: Warning: if cdrecord fails, try to run it from a root account.
    cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
    cdrecord: For possible targets try 'cdrecord -scanbus'.
    cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
    cdrecord:
    cdrecord: For more information, install the cdrtools-doc
    cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .

    ------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •