Find the answer to your Linux question:
Results 1 to 6 of 6

Thread: GTK Install

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942

    GTK Install


    Hello everyone, I've been trying to get GTK to make a GUI for mplayer, but during the install, I get the message that pkg-config says that glib was version 2.8.1 (I installed this manually), but version 2.6.4 was found (this is also the latest one I see on aptitude). How do I install glib 2.8.1 without interference from glib 2.6.4? I tried uninstalling it, but to no avail....and on a side note, why doesn't version 2.8.1 show up on aptitude?

    Thanks again!

  2. #2
    it is currently in experimental in debian
    Debian Package Search
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    oh did you run ldconfig
    Brilliant Mediocrity - Making Failure Look Good

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    Is there any particular directory I should untar the tar file in? I've been doing it in my home directory thus far, and that's probably the problem...=(

  6. #5
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    I'm started to get really frustrated...I just installed glib 2.8.1, but when I try configuring atk, I get this error message after entering ./configure:

    checking for GLIB - version >= 2.5.7...
    *** 'pkg-config --modversion glib-2.0' returned 2.8.1, but GLIB (2.6.4)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    checking for pkg-config... (cached) /usr/bin/pkg-config
    checking for GLIB - version >= 2.0.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.8.1, but GLIB (2.6.4)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no

    Please help me out! I'm so confused!

  7. #6
    -->
    what is must likely happening is that the new version is saved in
    Code:
     /usr/local/lib/pkgconfig
    . When you do the ./configure include that

    However, what I would do is try to install the debian package.
    http://packages.debian.org/experimen...bs/libgtk2.0-0
    Brilliant Mediocrity - Making Failure Look Good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •