Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
I have encountered the same problem several times: after having mounted the CD-ROM or USB and finished using it, I cannot unmount it because "...it is busy..." etc. So, the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1

    I have encountered the same problem several times:
    after having mounted the CD-ROM or USB and finished
    using it, I cannot unmount it because "...it is busy..."
    etc. So, the first thing to do is to ensure that you are
    not browsing the directory where the device has been
    mounted on, and also ensure that there are no processes
    doing the same. The latter is a bit tricky, because you
    might think there is no process, yet there might be.
    You can check this using the lsof command. In particular,
    the problem in my case (Debian 3.1 , Kernel 2.4.27, KDE 3.3),
    was that there was a setting enabled in Konqueror
    whereby it remembers the last (not sure how many) directories
    you have browsed, *even after you have closed the window*.
    This enhances performance but it also prevents you from
    unmounting your device. To disable this setting open:

    Konqueror>Settings>Configure Konqueror>Performance
    and in the Preload section choose
    Maximum number of instances kept preloaded =0

    Hopefully this will be useful.

  2. #12
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2
    Quote Originally Posted by gavroche
    I have encountered the same problem several times:
    after having mounted the CD-ROM or USB and finished
    using it, I cannot unmount it because "...it is busy..."
    etc. So, the first thing to do is to ensure that you are
    not browsing the directory where the device has been
    mounted on, and also ensure that there are no processes
    doing the same. The latter is a bit tricky, because you
    might think there is no process, yet there might be.
    You can check this using the lsof command. In particular,
    the problem in my case (Debian 3.1 , Kernel 2.4.27, KDE 3.3),
    was that there was a setting enabled in Konqueror
    whereby it remembers the last (not sure how many) directories
    you have browsed, *even after you have closed the window*.
    This enhances performance but it also prevents you from
    unmounting your device. To disable this setting open:

    Konqueror>Settings>Configure Konqueror>Performance
    and in the Preload section choose
    Maximum number of instances kept preloaded =0

    Hopefully this will be useful.
    Very useful! Thank you!
    I was using
    Code:
    lsof | grep /mnt/usb/ipod/whatever
    and kept noticing that konqueror was the culprit, but didn't know how to fix this behavior. I had to use kill to terminate konqueror.

    Thanks again.

  3. #13
    Just Joined!
    Join Date
    Jun 2009
    Posts
    2
    Quote Originally Posted by porkoboe View Post
    one way around this is to use

    umount -l <mounted fs ie /mnt/cdrom0>

    the -l unlinks /mnt/cdrom0 from fstab, at which point any apps
    with a lock on this directory cannot access it anymore.

    umount will then unmount the device normally

    this is the way i use to get around the "device is busy" thing

    meh. just read the man pages for umount it will give a better explanation


    This worked for me... thanks!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •