Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I am OFTEN unable to umount / eject a cd from the drive. The worst is when I am looking for something on a number of cd's and this problem ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    South Africa
    Posts
    55

    umount: /media/cdrom0: device is busy


    I am OFTEN unable to umount / eject a cd from the drive. The worst is when I am looking for something on a number of cd's and this problem rears its nasty head
    I keep getting the same error :

    umount: /media/cdrom0: device is busy
    umount: /media/cdrom0: device is busy
    Please check that the disk is entered correctly.
    Any information as to how to solve this irritating problem would be much appreciated.
    I close ALL windows under KDE (3.3.2) and attempting to 'umount' / 'eject' under Console or Root Console I get these errors
    The only way I can eject the cd is to log off (out of KDE) and log back on again.

  2. #2
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104
    I get these messages when i am looking at the contents of a CD and try to unmount
    My New years Resolution is 1280x1024

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Location
    Australia
    Posts
    39

    Ditto

    I've had the same problems are you, only with other distros like Mandriva. Basically there's not much you can do about it, probably the most likely cause is that a program is sitting in the background still holding an open lock on a file or something really trivial.

    You can probably just try removing the disk. While it is poor practice it might be the only thing you can do.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    May 2005
    Posts
    222
    try install "eject" .....

    #apt-get install eject

    that might solve your eject problem.

  6. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I don't have enough experience in Debian to have seen this problem, but in Fedora I do some or all of the following:

    Close any file managers and of course any other windows that show the Cd or whatever.
    Wait half a minute or so
    And if umount doesn't work for the normal user, do 'umount -l' as root user (that's a lower-case "L" for "lazy"). Almost always works....
    /IMHO
    //got nothin'
    ///this use to look better

  7. #6
    Linux Newbie
    Join Date
    Jul 2005
    Location
    Turn Around
    Posts
    202
    'cd ~' then umount

  8. #7
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3
    one way around this is to use

    umount -l <mounted fs ie /mnt/cdrom0>

    the -l unlinks /mnt/cdrom0 from fstab, at which point any apps
    with a lock on this directory cannot access it anymore.

    umount will then unmount the device normally

    this is the way i use to get around the "device is busy" thing

    meh. just read the man pages for umount it will give a better explanation

  9. #8
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3
    (ugh) apologies DrakeBasher. you already explained that 2 posts above.

    Sorry to anyone who had to read the same suggestion twice.

    Linux is confusing enough without having to read my dumbass posts.

  10. #9
    Just Joined! praka123's Avatar
    Join Date
    Jan 2006
    Location
    Kerala,India
    Posts
    35

    Smile

    in debian,it often happens.just try to find out what is preventing umount by issuing
    Code:
    lsof |grep /dev/cdrom
    In my case,i found "famd" is responsible for that!

  11. #10
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1
    I was having the same problem.

    cd ~
    umount

    Fixed it right up.
    Thanks DoctorDan.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •