Find the answer to your Linux question:
Results 1 to 9 of 9
I have installed a 2GB hard disk on my old celeron 333 which is formatted under NTFS. I want to format it under ReiserFS or Ext3 file systems. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie exploder's Avatar
    Join Date
    Jun 2005
    Location
    127.0.0.1
    Posts
    164

    How to format a hard disk?


    I have installed a 2GB hard disk on my old celeron 333 which is formatted under NTFS. I want to format it under ReiserFS or Ext3 file systems. I have tried formatting using "cfdisk" but when I select [Delete] option in CFDISK & selecting the type of file system I want by entereing "t" it appears like it has done its job but when i "quit" and check again thru cfdisk /dev/hdb still I can see the new 2GB harddrive is still in NTFS!!!!
    Registered Linux User#394486

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    There is a write option somewhere in there. You can make all of your changes to the disk but you need to write them when you are done. If you don't write it, it will appear as if you made a bunch of changes when in fact you didn't.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    8

  4. #4
    Linux Newbie exploder's Avatar
    Join Date
    Jun 2005
    Location
    127.0.0.1
    Posts
    164
    Cool I have formatted it with Linux file system. But I can't write anything into it. It says its a read only drive!!
    Registered Linux User#394486

  5. #5
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    Mount the partition manually with the following command:
    Code:
    # mount -o rw /dev/hdb1 /mnt/hdb1
    or you can edit your /etc/fstab to mount it read-write at boot, the entry should look something like this:
    Code:
    /dev/hdb1 /mnt/hdb1 rw 1 1
    just make sure that the fourth section in the etry contains 'rw' and not 'ro'.

    If you use KDE there might be an option to rmount the drive as read/write if you right click on it but I'm not sure about that.

  6. #6
    Linux Newbie exploder's Avatar
    Join Date
    Jun 2005
    Location
    127.0.0.1
    Posts
    164
    mmm! even after mounting through "rw" permissions still it says "read only file system"!
    I have updated the /etc/fstab so that it mounts automatically when the pc boots.

    I am wondering the "Linux" file system in hdb1 which I have created through "cfdisk" is it properly recognised in my pc?

    If it doesn't work I will try "parted" as advised by "tellyousomeday".

    Thank you fellas for your lightning fast replies
    Registered Linux User#394486

  7. #7
    Linux User nalg0rath's Avatar
    Join Date
    Sep 2004
    Location
    Stockholm
    Posts
    303
    Odd, what filesystem did you end up using for the partition? Ext2, Ext3, Reiser?
    You dont have to use parted if you're not resizing partitions, it is uneccessarry, Parted is just a GUI frontend for the filesystem tools that are very easy to use from command line - and there is no difference in the result.

    To format the partition with ext3:
    Code:
    # mke2fs -j /dev/hdb1
    ext2:
    Code:
    # mke2fs /dev/hdb1
    reiser:
    Code:
    # mkreiserfs /dev/hdb1
    EDIT: It can also be useful to look what the output is of:
    Code:
    # mount -v -o rw /dev/hdb1 /mnt/hdb1
    to see if you can see what is wrong.

  8. #8
    Linux Newbie exploder's Avatar
    Join Date
    Jun 2005
    Location
    127.0.0.1
    Posts
    164
    Thank you nalg0rath its working now...
    Registered Linux User#394486

  9. #9
    Just Joined!
    Join Date
    May 2007
    Posts
    1
    Thanks nalg0rath. Seems to be working for me also (ubuntu 6.10 32bit). Partitioned with cfdisk, formatted in ext3 using mke2fs, and mounted. I also had to chmod the file system after it was mounted to get write access to it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •