Find the answer to your Linux question:
Results 1 to 4 of 4
I have read the man pages for apt-cdrom and done some searches and reading on this but I'm not finding what I need. I have zen 1.2.3 installed and working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7

    apt-cdrom error


    I have read the man pages for apt-cdrom and done some searches and reading on this but I'm not finding what I need.
    I have zen 1.2.3 installed and working ok. I wanted to try and upgrade it with sid. Not the entire install just some problem areas. I downloaded an unofficial debian unstable cd from a public wifi place and burned it. It mounts fine and will even start to install but I'm not interested in installing it over zen. The point is I can mount the cd and cd to the files on it. However when I try to use apt-cdrom (which is suppose to add the cd to my sources.list) this is the results: [root@zen:/etc]# apt-cdrom add
    Using CD-ROM mount point /cdrom/
    Unmounting CD-ROM
    Please insert a Disc in the drive and press enter
    Mounting CD-ROM
    E: Failed to mount the cdrom.
    It doesn't matter if I include the actual mount point of the cdrom (/dev/hdc) or use (/cdrom1 which is the listing for the cdrom in the filesystem) I still get the same results.
    I'm including the fstab that the zen installer generated and I'm currently using
    proc /proc proc defaults 0 0
    /dev/hda7 / ext2 defaults,acl,errors=remount-ro 0 1
    /dev/hda5 none swap sw 0 0
    /dev/hdd /cdrom0 iso9660 noauto,owner,ro 0 0
    /dev/hdc /cdrom1 iso9660 noauto,owner,ro 0 0

    hdd is the cdwriter hdc is the cdrom/dvd reader

  2. #2
    Linux Newbie
    Join Date
    Dec 2005
    Location
    Pennsylvania
    Posts
    102
    try placing the cd in your /dev/hdd/cdrom0 drive, and type the command
    Code:
    apt-cdrom -a

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7
    Quote Originally Posted by vidd
    try placing the cd in your /dev/hdd/cdrom0 drive, and type the command
    Code:
    apt-cdrom -a
    Thanks for the reply. I should have included that I had tried that also. Doesn't work-same error output as apt-cdrom add. Whoops I didn't try the burner (hdd) why would I want to use that drive? I logged into Zen and tried that-no luck. I also tried apt-cdrom ident. I just keep getting that same error message
    E: Failed to mount the cdrom.
    Happy New Year 2 All!

  4. #4
    Just Joined!
    Join Date
    May 2010
    Posts
    1
    First unmount the cd/dvd rom

    sudo umount /dev/sr0

    Then mount it into /media/apt/

    sudo mount /dev/sr0 /media/apt/


    Next run

    sudo apt-cdrom add

    I did the this and worked for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •