Find the answer to your Linux question:
Results 1 to 3 of 3
Hi All, I have a couple of issues that I need some help on. The intranet I work on is a Windows NT Domain. I have installed a Debian Linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6

    Apache intranet authentication for webapps


    Hi All,
    I have a couple of issues that I need some help on.

    The intranet I work on is a Windows NT Domain. I have installed a Debian Linux server with Apache2 and am hosting several webapps (PHP and MySQL based mainly) there. The problem is that each of them require users to sign up before they are used. What I have to do is work around this problem.
    For this I want the Apache server to authenticate a user when they try to view a web page there. When a user access the webapp.
    Apache should authenticate them by connecting to the LDAP (??) server and if it is a valid user connecting for the first time should add an entry in the database or if an entry already exists then should just allow them to access the app.
    If the user is not a valid user (Apache should let me know this) then display and error.
    Does this sound correct?

    My next problem is...
    On the Debian server I installed Apache2 deb and when I try to see what modules are present with Apache I get this
    Code:
    Compiled in modules:
      core.c
      mod_access.c
      mod_auth.c
      mod_log_config.c
      mod_logio.c
      mod_env.c
      mod_setenvif.c
      prefork.c
      http_core.c
      mod_mime.c
      mod_status.c
      mod_autoindex.c
      mod_negotiation.c
      mod_dir.c
      mod_alias.c
      mod_so.c
    I downloaded the libapache-auth-ldap deb and then did a 'dpkg -i libapache-auth-ldap' which told me the package was successfully installed, but even after that could not see the ldap auth module with apache.
    How do I get this working and how do I know it is working.
    Any help on this would be greatly appreciated. Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6
    I just found out that the Windows Domain is a Windows 2003 Domain. It has an LDAP interface (whatever that means).
    so does anyone know how I can get webapps to authenticate against that?

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •