Find the answer to your Linux question:
Results 1 to 2 of 2
I recently installed Debian AMD64 Sarge and everything worked great except for VNC. I first tried tightvncserver, but it segfaults ( http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=276948 ). I did a little searching around and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Location
    So-Cal
    Posts
    17

    VNC not running Apps


    I recently installed Debian AMD64 Sarge and everything worked great except for VNC. I first tried tightvncserver, but it segfaults (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=276948). I did a little searching around and came across this thread: http://ubuntuforums.org/archive/index.php/t-82548.html , which a poster said they had used debs from another location and it worked.

    After installing these debs vnc4server worked fine for a couple of days, then after running Diablo II with cedega in my vncsession I noticed I couldn't start any new apps. Killing/restarting the vncserver just produced a grey X screen and cursor. Looking at the logs in ~/.vnc/ didn't show anything unusual, but even after restarting the machine the same thing happened.

    All that I can think of hasn't worked, using a different vncserver, building from source, using a different display number, different window manager, etc.

    Here's what I've learned so far:

    1. When running `vncserver :02` I get the follwing:

    New 'jezebel:02 (micheal)' desktop is jezebel:02

    Starting applications specified in /home/micheal/.vnc/xstartup
    Log file is /home/micheal/.vnc/jezebel:02.log

    2. ~/.vnc/xstartup is:

    #!/bin/sh

    #[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
    xclock &
    xterm &

    3. ~/.vnc/log is:

    Xvnc version 4.0 - built Oct 19 2005 20:33:37
    Underlying X server release 40300001, The XFree86 Project, Inc

    Fri Mar 17 09:35:11 2006
    vncext: VNC extension running!
    vncext: Listening for VNC connections on port 5902
    vncext: created VNC server for screen 0
    Could not init font path element /usr/X11R6/lib/X11/fonts/freefont/, removing from list!
    Could not init font path element /usr/X11R6/lib/X11/fonts/sharefont/, removing from list!

    4. Any apps (excpect window managers) won't show on the X screen, but they do appear as a process. So for instance when I run vncserver :02 I see the grey screen, but when I grep for 'xterm' or 'xclock' in ps they show up.

    5. GDM displays when using '-query localhost', but this is unstable and restarting GDM loses the session.

    6. I'm seeing nothing in /var/log, there's no information about anything crashing or even and indication that something is going wrong.

    I'm going to try the rpm/alien solution here, http://lists.debian.org/debian-amd64.../msg00549.html , but it's something I'd rather avoid.

    Should I report this bug to debian? Since AMD64 isn't really "official" and it's a known problem with tightvnc I don't think it is anything new.

    Thanks for any help you can give.

    Micheal

  2. #2
    Just Joined!
    Join Date
    Sep 2004
    Location
    So-Cal
    Posts
    17
    I'm an idiot, it was a problem with my /etc/hosts. The hostname of the machine must be related to 127.0.0.1 not a real IP address. It only did this after I tried diablo II because D2 needs the hostname to have a real IP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •