Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, I installed some software and later removed that software. The software had some packages that contained printer drivers. The packages were removed but apt-get/aptitude/dpkg didn't notice that they ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3

    Can't delete packages on Debian Sarge


    Hi all,

    I installed some software and later removed that software. The software had some packages that contained printer drivers. The packages were removed but apt-get/aptitude/dpkg didn't notice that they were removed. Now when I try to install CUPS first apt-get tries to remove those already removed packages. Since they are not there apt-get can't go on with the installation.

    I already tried deleting the packages manually but with no luck either (since they are not there!)

    how can I tell aptitude/dpkg/apt-get to forget about those packages??

    I am close to throwing myself out the window. This is a bad thing since I work on the second floor and I think that I will only break my spine instead of dieing and sit in a wheelchair for the rest of my life.
    Any ideas before I take a chance with the window??

    Thanks, Dekers

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    How did you remove the software?
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3
    I actually tried everything I found in my debian book about deleting packages but it still didn't work

    The solution: after uninstalling the package from ESP (the developers of CUPS) I had to manually copy the file '/usr/sbin/cupsd' from another system I have because the software from ESP somehow corrupted the file. After that I also had to copy /usr/lib/libcups.so.2 from the other system. After that everything went as smooth as a baby's bottom. I could install and configure CUPS without problems

    thanks for effort

    Roy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •