Find the answer to your Linux question:
Results 1 to 4 of 4
Hello all, This is my first post here on the forum. This is also my first experience installing Linux on a computer. I have a Toshiba Sattelite M35X-A111 where I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Location
    Iowa
    Posts
    2

    Pcmcia wireless card woes for a newb


    Hello all,

    This is my first post here on the forum. This is also my first experience
    installing Linux on a computer. I have a Toshiba Sattelite M35X-A111
    where I am trying to get my wireless internet to work through my pcmcia slot.
    The card that I am using is a Linksys WPC54GS wireless G notebook adapter.

    Here's what I have done so far. In my ignorance, I installed Debian with a 2.2 kernel on the machine. Nothing worked right in that setup. Then I installed
    by way of net-install Debian with a 2.4 version. I was able to get X working
    with little trouble and the wireless card at least lights up now. Then I
    thought that upgrading the kernel to 2.6.8 might be an even better idea,
    thinking that there would be more wireless support with a later version.
    Well, when I boot up with 2.6.8, the card doesn't light up at all. Its like
    I have taken a step backwards. Therefore, I have chosen to try to get the card
    working with the 2.4 kernel.

    I have taken to doing a lot of google searches trying to find out what I
    need to know to get the card working. I am afraid that I am ignorant to
    the ways of networking and scripting. I have been making modifications to
    /etc/pcmcia/wireless.opts and /etc/pcmcia/network.opts as found on a
    few websites, but nothing seems to register.

    Here's some information that I am getting:

    lspci:

    0000:02:04.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
    0000:03:00.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)


    iwconfig:

    Simply state that lo and eth0 have no wireless extensions


    ifconfig:

    Just information about eth0 and lo... no wireless or pcmcia info


    cardctl ident:

    Socket 0:
    product info: "Broadcom", "802.11b CardBus", "8.0"
    manfid: 0x02d0, 0x0406
    function: 6 (network)


    /etc/pcmcia/wireless.opts:

    I added some lines in the attempt to have the wireless card be recognized as
    follows (This could easily be one of my pitfalls) -

    # Broadcom Corporation BCM4306 802.11b/g Wireles LAN Controller
    home,*,*,*)
    ESSID="laptop-home"
    MODE="auto"
    ;;



    Any help getting this card to work would be greatly appreciated.

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    I would suggest getting the newest debian installer cd and when the boot menu comes up type linux26 to install a fresh debian with a 2.6 kernel. you were right in thinking you would have better wireless support with the 2.6 kernel.

    then you need to use ndiswrapper to get your card working
    http://www.netdigix.com/downloads/de...ess-howto.html
    scroll down to # 2 for the ndiswrapper install instructions.

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Location
    Iowa
    Posts
    2

    Thanks for the reply

    Thank you for the link. Unfortunately, I was still unable to get the card to work properly. I even tried buying a different wireless card. In the end, I decided to put a wireless pci card in the desktop computer and use a long ethernet cord for the one connection on the router.

    Now that i have stopped beating my head against the wall over the wireless issue, I am enjoying setting up my system the way i want.

    Thank you
    Arog

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    1
    What I am tryingto do nowadays is to upgrade my kernel to 2.6.16. Once I do that, I will go to http://bcm43xx.berlios.de/ and follow the instructions there to load the driver for my USRMAXg wireless adapter.

    In your case, I would better go on with jledhead had said. You will find much better support with 2.6 kernel [Sarge installs 2.6.8].

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •