Find the answer to your Linux question:
Results 1 to 3 of 3
Having given up on a HD installation of Knoppix 5.0, I've installed Debian 3.1r1. The problems I was having with Knoppix have all gone away - the SCSI DVDROM appears, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Location
    Alternating between Essex and Norfolk, both in England.
    Posts
    48

    Video and hard drives missing?


    Having given up on a HD installation of Knoppix 5.0, I've installed Debian 3.1r1.

    The problems I was having with Knoppix have all gone away - the SCSI DVDROM appears, the sound system works, Samba works so far.

    BUT ... I have new problems I'd very much appreciate the help of anyone who can.

    The other two hard drives in the machine hda (NTFS) and hdc (Fat32) don't appear. They were fine in all Knoppix versions from 3 upwards. They aren't in Debian's FSTAB either. They do appear in the writing that scrolls past too fast to read it at bootup time.

    fdisk /dev/hda or /dev/hdc brings up the message "Unable to open /dev/hd.."

    The display won't go above 800 x 600, where it should be happy at 1024 x 768. I know the max rate settings for the monitor, but not how to update them in Debian.

    A lesser glitch: CUPS says it works, but it doesn't seem able to see the printers on the other machines on the network.


    What am I doing wrong that prevents hda and hdc from showing? Debian installed from DVD with virtually no intervention from me.

    Where can I change the video settings to allow my monitor to work?

    All advice most welcome.

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    Alternating between Essex and Norfolk, both in England.
    Posts
    48
    Well, I fixed the hard drive one - it was a case of creating the folders manually and editing the relevant details into fstab. Hard drives all present and correct!

    Still no joy on 1024x768 display, though.

  3. #3
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Well, you could run configure-debian (in a console, as root with X access), dpkg-reconfigure xserver-xorg (or xserver-xfree86 if that's what's installed), or edit /etc/X11/xorg.conf (or /etc/X11/XF86Config if that's what's installed) and add the resolutions you want to the "Screen" Section.
    Stand up and be counted as a Linux user!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •