Find the answer to your Linux question:
Results 1 to 5 of 5
It seems I've finished installing Debian 3.0r4 from CD But when I start up the machine, I get a graphical login screen where I've tried with the two users I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    13

    Problems installing Debian


    It seems I've finished installing Debian 3.0r4 from CD
    But when I start up the machine, I get a graphical login screen where I've tried with the two users I defined in installation, one of them root, and I get a message in the right bottom corner saying "can't locate module char-major-13"
    I can't do anything, because if I can't login I can't edit, reinstall or configure anything.
    Any hint?
    Thanks a lot in advance

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Is there a way for you to log in non-graphically? According to this thread, this is apparently caused by a problem with xdm, and can be fixed by removing xdm and reinstalling it. In order to do that however, you must be able to log in non-graphically.

    Did you install GRUB or LILO as a bootloader?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    to login non-graphically from debian's gdm or xdm, i think it defaults solely to gdm now...just hit ctl-alt-f1 at the graphical login and you will change vts and be a non-graphical login. If you can login as root, then stop the graphical service with, if its gdm "/etc/init.d/gdm stop" and then login as a non-root user and see if startx works, if so then it is just a borking of your dm. Tell us if this clears things up, if so, just reinstall gdm if you want it, if not, startx is only one little command away
    Operating System: GNU Emacs

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    13
    I didn't know I could enter in text mode by means ofCtrl+Alt+F1
    It works, but startx doesn't work. I get theses lines on the screen:

    Xlib: connection to ".0.0" refused by server
    Xlib: Invalid MIT-MAGIC-COOKIE-1 key
    giving up.
    xinit: unable to connect to X server
    xinit: No such process (errno 3): Server error.

  6. #5
    Just Joined!
    Join Date
    Apr 2006
    Posts
    13
    I found in another forum that someone fixed this problem by adding Off in the DPMS Option of /etc/X11/XF86Config-4 file
    I did the same and then, the login process could proceed

    Thank you both for your answers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •