Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Does anyone konw of a substitution for I-tunes, since I-tunes can't be run on Linux Debian?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    28

    ITunes Alternative


    Does anyone konw of a substitution for I-tunes, since I-tunes can't be run on Linux Debian?

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Are you looking for strictly the music management style of iTunes or also iPod compatibility? The closest I've found to the style would be either amaroK or LSongs, or perhaps banshee. I've had only marginal success getting any of these to sync with my iPod though, and it really depends on whether your individual distribution has iPod support. SuSE for instance was the distro that gave me the most success with my iPod nano.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I believe both Amarok and Banshee have just had their iPod sync capability improved greatly. I'm an amarok person myself but a lot of people who use iTunes claim Banshee is quite good as a drop in substitute.

  4. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    You can even look here, if you want an extended list:
    http://en.wikipedia.org/wiki/Compari..._media_players

    As said earlier, the most popular are Amarok, Rhythmbox and Banshee.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  5. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    28
    Does Amarok open apple streaming media when it is embeded in a web page, like with apple media player?

    And also I can not get my ipod to get sync with Amarok... the ipod screen says "Do Not Disconnect".

    Any Help Appreciated
    Thanks Again

  6. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    50
    Quote Originally Posted by InvisibleSniper
    Does Amarok open apple streaming media when it is embeded in a web page, like with apple media player?
    I couldn't say about Amarok, I've installed it then never gotten around to trying it out. I do know vlc will play the apple streams. Embedded ones I'm not sure, I think there's a mozilla/firefox plugin for it.

  7. #7
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    I just installed Suse 10.1 and Banshee. My iPod has had complete success - it has worked like a charm and will mount/unmount properly. I was able to play songs from it well with little to no delay and skipping. The interface, while different, will feel familiar to iTunes users. As for the music store, you're out of luck.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #8
    Just Joined!
    Join Date
    May 2006
    Posts
    28
    I have just been trying to find out a way to install banshee on my debian box... but I can't seem to find an easy way. Basically I have spent about 2hrs trying to work out how I can do it, only to come up with the sollution of installing about 50packages manually and building them manualy.
    Code:
    This is the output from the terminal window:
    Depends: libatk1.0-0 (>= 1.9.0) but 1.8.0-4 is to be installed
               Depends: libbonobo2-0 (>= 2.13.0) but 2.8.1-2 is to be installed
               Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge3 is to be installed           Depends: libcairo2 (>= 1.0.2-2) but it is not installable
               Depends: libdbus-1-2 (>= 0.61) but it is not installable
               Depends: libdbus-glib-1-2 (>= 0.61) but it is not installable
               Depends: libgconf2-4 (>= 2.13.5) but 2.8.1-6 is to be installed
               Depends: libglib2.0-0 (>= 2.10.0) but 2.6.4-1 is to be installed
               Depends: libgnome-desktop-2 (>= 2.11.1) but 2.8.3-2 is to be installed
               Depends: libgnome-keyring0 (>= 0.4.3) but 0.4.2-1 is to be installed
               Depends: libgnome2-0 (>= 2.14.1) but 2.8.1-2 is to be installed
               Depends: libgnomecanvas2-0 (>= 2.11.1) but 2.8.0-1 is to be installed           Depends: libgnomevfs2-0 (>= 2.13.92) but 2.8.4-4 is to be installed
               Depends: libgstreamer0.10-0 (>= 0.10.5) but it is not installable
               Depends: libgtk2.0-0 (>= 2.8.0) but 2.6.4-3.1 is to be installed
               Depends: libhal1 (>= 0.5) but it is not installable
               Depends: libnautilus-burn2 but it is not installable
               Depends: libpango1.0-0 (>= 1.12.1) but 1.8.1-1 is to be installed
               Depends: libxfixes3 but it is not installable
               Depends: libxinerama1 but it is not installable
               Depends: libxml2 (>= 2.6.24) but 2.6.16-7 is to be installed
               Depends: mono-runtime (>= 1.0) but it is not installable
               Depends: libdbus-1-cil (>= 0.61) but it is not installable
               Depends: libgconf2.0-cil (>= 2.7.90) but it is not installable
               Depends: libglade2.0-cil (>= 2.7.90) but it is not installable
               Depends: libglib2.0-cil (>= 2.7.90) but it is not installable
               Depends: libgnome2.0-cil (>= 2.7.90) but it is not installable
               Depends: libgtk2.0-cil (>= 2.7.90) but it is not installable
               Depends: libipoddevice0 (>= 0.4.5) but it is not installable
               Depends: libmono-corlib1.0-cil (>= 1.0) but it is not installable
               Depends: libmono-security1.0-cil (>= 1.0) but it is not installable
               Depends: libmono-sqlite1.0-cil (>= 1.0) but it is not installable
               Depends: libmono-system-data1.0-cil (>= 1.0) but it is not installable
               Depends: libmono-system-web1.0-cil (>= 1.0) but it is not installable           Depends: libmono-system1.0-cil (>= 1.0) but it is not installable
               Depends: libmono1.0-cil (>= 1.1.13.6) but it is not installable
               Depends: libmusicbrainz4c2a (>= 2.1.2) but it is not installable
               Depends: gconf2 (>= 2.10.1-2) but 2.8.1-6 is to be installed
               Depends: gstreamer0.10-plugins-base but it is not installable
               Depends: gstreamer0.10-plugins-good but it is not installable
               Depends: gstreamer0.10-plugins-ugly but it is not installable
               Depends: gstreamer0.10-gnomevfs but it is not installable
      zlib1g: Depends: libc6 (>= 2.3.5-1) but 2.3.2.ds1-22sarge3 is to be installed
    Anyone Know Of An Easeir Way? Isn't there some command that can tell apt-get install to get the rest of the needed packages automatically or do I have to get each one manually?

    Thanks Again In Advance.

  9. #9
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Which version of Debian are you using?

    What is the exact banshee package you are trying to install?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  10. #10
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    I bet the problem is that InvisibleSniper is trying to install the sid version of banshee (that is the only version debian has currently). The problem is banshee is rather young.
    Brilliant Mediocrity - Making Failure Look Good

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •