Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all. I run Debian "Etch" with KDE 3.5.5. Recently, I upgraded my kernel to 2.6.17-2-686. I am now experiencing the following sound issues: KsCD plays but I have no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Location
    Western Australia
    Posts
    3

    Sound Problems > KDE 3.5.5


    Hi all.

    I run Debian "Etch" with KDE 3.5.5. Recently, I upgraded my kernel to 2.6.17-2-686.

    I am now experiencing the following sound issues:

    KsCD plays but I have no sound;

    In: Control Center > Sound & Multimedia > Sound System: When I press the "Test Sound" button, I get the test sound. This is THE ONLY time I get any sound !!

    Anyone have any clues?

    Cheers.

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Location
    Western Australia
    Posts
    3
    Hi folks !!!
    I am happy. As I write this I am listening to Mozart's 'Eine kleine Nachtmusik' courtesy of KsCD. Now this is odd. After posting my initial complaint yesterday I had not altered any more settings. I booted up this morning and found that KDE was giving me sound on icon manipulations, the first time since the new kernel upgrade.

    Prior to posting this topic, I had carried out a major kernel upgrade (which was followed by a regular update, upgrade & dist-upgrade sequence on 6 nov). I also installed 2 HAL components (hal-device-manager & hal-doc).

    This was followed by a shutdown, sound card removal, blow clean of the PCI interfaces, sound card replacement, machine start up and accessing KMix, turning on and adjusting the Master and PCM controls. Still no sound at all (speakers were definitely plugged in and switched on). As said at the beginning of this thread, pressing the "Test Sound" button in Control Center > Sound & Multimedia > Sound System was THE ONLY time I got any sound. It was after this that I posted my complaint here and not long after, shutdown the machine overnight.

    I booted up this morning to find that I had sound each time a KDE icon was manipulated.

    Now I was excited !! Naturally, I inserted a CD and accessed KsCD and pressed play. CD played with NO sound. I then carried out the following actions: > KsCD > Extras > Configure KsCD > CD Player > Placed a tick in the check box "Use direct digital playback" and at "Select audio backend" I chose "arts". RESULT: Success !! Hence the Mozart.

    Further testing using "alsa" as the audio backend would allow sound output ONLY during the CURRENT KsCD session on which the configuration had been made, if I was lucky. Subsequent re-launch of KsCD would, on the majority of attempts, yield the following warning dialogue: "CD-ROM read or access error (or no audio disc in drive). Please make sure you have access permissions to: /dev/cdrom". After this KsCD would not play.

    Selecting "arts" as the audio backend has so far, been a success on every occasion. I have yet to test after a KDM shutdown, machine re-boot and shutdown.

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    6
    I have installed Debian on a few computers in the last 6 months, I use etch and have a few updates from sid. One thing I noticed right away with my installs is that you must reconfigure all the media players to look at the correct drive configuration, for example: my setup is this, I have two hard drives and a cd burner and a dvd burner ( 2 separate cd drives)
    (take note of the drive lettering)
    dev/hda1=windows
    dev/hdb1=media
    dev/hdb2=data
    dev/hdb5=root
    dev/hdb7=home
    dev/hdc=media/cdrom0 (cdburner)
    dev/hdd=media/cdrom1 (dvdburner)
    when you configure your media players ( KsCd for example ) make them point to your device--not the mount point. --In my case when I set up KsCD
    I had to configure it to use dev/hdc not dev/cdrom0
    I use alsa and I make sure all the settings in Kmix are correct ( move the sliders up!-especially PCM) open up settings/configure kmix ,check all the boxes and exit -you will have volume controll on a handy little icon on your taskbar and can controll volume by either the slider or by rolling the scroll wheel when the pointer is on the icon!
    Hope this helps you!

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Location
    Wellington Somerset UK
    Posts
    3
    It helped me too. I recently installed Debian testing (etch) with 2.6.17-2-amd64
    and KSCD produced no sound. I d/l a .wav file and this played ok when I clicked the icon on the desktop. I did what you suggested and set the device to /dev/hdc and sound driver alsa and now I can hear Benny Goodman play Stomping at the Savoy. One thing is still not working tho; The slider in KSCD is
    grey and doesn't move. I can decrease the volume in Kmix with the PCM slider. Any idea where I might be going wrong?

  5. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    6

    sound

    One thing you might want to check is that you have an audio cable attatched from your cdrom drive to your motherboard/soundcard. Its a simple thing but I have found that it makes a difference! also, go to extras in KsCD (bottom right corner of player) and then configure KsCD. Make sure that the path to the cd drive is correctly entered. You can play with the check box for direct digital playback and see if it helps at all (mine is not checked-and everything works)

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Location
    Wellington Somerset UK
    Posts
    3
    I checked all these things and the sound is fine but the volume slider in KsCD is still not working. However I can change the volume with the mixer so it is not really important.

  7. #7
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    Thanks!

    Hey thanks so much for the help. I was having the same basic problem. I got sounds from everything except the CD-ROM, I even got sound from watching a DVD, but not from listening to CDs. For other people trying to fix this problem:
    Everything should work with defaults if you have the thin, round, grey cable attatched from your CD-ROM drive to the sound card or motherboard (onboard audio). I couldn't do this because I'm working with an old machine which has some sort of proprietary CD Audio in connector. If the cable is not connected, follow cecram's directions:
    following actions: > KsCD > Extras > Configure KsCD > CD Player > Placed a tick in the check box "Use direct digital playback" and at "Select audio backend" I chose "arts".
    If you get an error saying "CD-ROM read or access error (or no audio disc in drive). Please make sure you have access permissions to: /dev/cdrom" there is a box that says "Select Audio Device"; put /dev/cdrom in that box. That should fixed the error for me. Thanks again!

  8. #8
    Just Joined!
    Join Date
    Nov 2006
    Location
    Western Australia
    Posts
    3
    Cheers, no worries.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •