Find the answer to your Linux question:
Results 1 to 4 of 4
Hello! I'm trying to use apt-get to get the packages gcc-avr, avr-libc, and gdb-avr on Debian Etch. However, I get a segmentation fault: Reading package lists... Done Building dependency tree... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12

    Apt-get segmentation fault


    Hello!

    I'm trying to use apt-get to get the packages gcc-avr, avr-libc, and gdb-avr on Debian Etch. However, I get a segmentation fault:

    Reading package lists... Done
    Building dependency tree... Done
    The following extra packages will be installed:
    binutils-avr
    Suggested packages:
    task-c-devel gcc-doc
    Segmentation fault

    What causes this, and how should I go about solving the problem?

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    what does running
    Code:
    apt-get -f install
    result in?
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2
    I had a similar problem and this command (from terminal) as root fixed it:

    rm -rf /var/cache/apt/*.bin

    Hope that helps

  4. #4
    Just Joined!
    Join Date
    Apr 2009
    Posts
    1

    segmentation fault in apt-get ubuntu

    thankx a lot it worked!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •