Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
I'm brand new to Linux. I installed Etch today on my Dell Inspiron 5100 which has a Broadcom BCM4309 internal wireless controller, eth2 on my system. Eth1 works fine with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    12

    Broadcom wireless troubles


    I'm brand new to Linux.

    I installed Etch today on my Dell Inspiron 5100 which has a Broadcom BCM4309 internal wireless controller, eth2 on my system. Eth1 works fine with network cable run to the LAN port on my wireless router (D-Link DI-624). However, the wireless card doesn't seem to be working. I keep putting in the info for my home wireless network but nothing is detected. IWCONFIG says:

    ESSID: off/any
    Nickname: Broadcom 4306
    Mode: Managed
    Access Point: Invalid
    RTS thr: off
    Fragment thr: off
    Encryption key: off
    Link Quality: 0
    Signal level: 0

    I have a copy of the Broadcom b44 Linux driver, and I think I have extracted some files into a directory. However, the instructions that came with the driver say I need to "build the driver as a loadable module for the running kernel." I am supposed to do the following:

    cd src Typing this at command line resulted in NO SUCH FILE
    make

    Am I on the right track? How do I build a driver? Thanks in advance for any help.

    MB

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    You might take a look at http://www.larsen-b.com/Article/256.html
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Posts
    12

    Broadcom wireless troubles

    Per the article I did find the BCM43xx-fwcutter as a .deb file which I have loaded on a cd. However, I can't get any of the package management programs to find it on the cdrom0. I keep getting "can't find package" messages using apt-get, aptitude and Synaptic.

    The command I am using is
    aptitude install /media/cdrom0/bcm43xx-fwcutter_006-1_i386.deb

    Is this syntax wrong? Thanks.

    MB

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by barronmo
    The command I am using is
    aptitude install /media/cdrom0/bcm43xx-fwcutter_006-1_i386.deb

    Is this syntax wrong?
    More like:
    Code:
    dpkg -i bcm43xx-fwcutter_006-1_i386.deb
    Or
    Code:
    aptitude install bcm43xx-fwcutter
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #5
    Just Joined!
    Join Date
    Apr 2007
    Posts
    12
    Thanks. The following worked:

    dpkg -i /media/cdrom0/bcm43xx-fwcutter_006-1_i386.deb

    The radio is now turned on and I can see my access point's SSID. However, despite entering the WEP key and checking to make sure the settings matched, the connection still isn't established.

    I've tried:

    dhclient eth2

    but it won't give me an IP address. Any other ideas. I have other computers working on the network so I think the router is OK. Thanks,

    Mike

  7. #6
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Have you tried using NetworkManager? The default install of Etch comes included with it pre-configured. Next to the time somewhere, you should see an icon that resembles two computers for lack of a better description. If you have successfully installed your firmware using bcm43xx-fwcutter, your SSID should show up when you click the NM applet. Click your SSID and you should be good to go.
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #7
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    try
    Code:
    iwconfig interface essid "essid_name" key "wepkey"
    Brilliant Mediocrity - Making Failure Look Good

  9. #8
    Just Joined!
    Join Date
    Apr 2007
    Posts
    12
    I do have the Network Manager applet but it isn't mentioning anything about my wireless access point. However, if I try

    iwlist eth2 scanning

    It sees mine home network and the neighbors. Neither shows up in Network Manager unfortunately. Any ideas why? Thanks.

  10. #9
    Just Joined!
    Join Date
    Apr 2007
    Posts
    12
    iwconfig interface essed "dlink" key "*********"

    returned this error:

    Error for wireless request "Set ESSID" (8B1A) :
    Set failed on device interface ; No such device.

  11. #10
    Just Joined!
    Join Date
    Apr 2007
    Posts
    12
    Is my interface "eth2"? I tried it that way and didn't get an error. Still not working however.

    Mike

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •