I was trying to follow the instructions and figure out how can i make it work
Hi, i am also new to Linux, and i was trying to setup 2 nics on the same computer using Ubuntu, the problem is that one nic is recognized and the other one is not. But both nics are the same brand and chipset RTL8139.

I was trying to follow the instructions you have given before, and figure out something that makes it works. But i have no clue how to make both nics be recognized.

I forgot to mention that i also tried "modprobe 8139too" or "modprobe 8139" don't know which one is the correct. And nothing seems to happen.

Thanks in advance.

This is the info that is output after i followed your instructions:

root@zerg:/# lspci | grep -i ethernet

0000:00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 0)
0000:00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


root@zerg:/# dmesg | grep eth

[4294678.927000] eth0: RealTek RTL8139 at 0xdc00, 00:08:54:3f:18:71, IRQ9
[4294678.927000] eth0: Identified 8139 chip type 'RTL-8100B/8139D'
[4294724.059000] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[4294736.938000] eth0: no IPv6 routers present

root@zerg:/# uname -a

Linux zerg 2.6.12-9-386 #1 Mon Oct 10 13:14:36 BST 2005 i686 GNU/Linux

root@zerg:/# dmesg | tail
[4294750.594000] Bluetooth: L2CAP ver 2.7
[4294750.594000] Bluetooth: L2CAP socket layer initialized
[4294750.675000] Bluetooth: RFCOMM ver 1.5
[4294750.675000] Bluetooth: RFCOMM socket layer initialized
[4294750.675000] Bluetooth: RFCOMM TTY layer initialized
[4295097.579000] ibm_acpi: ec object not found
[4298763.852000] atkbd.c: Unknown key pressed (translated set 2, code 0xaa on isa0060/serio0).
[4298763.852000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
[4298763.962000] atkbd.c: Unknown key released (translated set 2, code 0xaa on sa0060/serio0).
[4298763.962000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.

root@zerg:/#