Find the answer to your Linux question:
Results 1 to 10 of 10
Hi, linux newbie here looking for help with an install problem. I downloaded via BT the full DVD ISO's for etch/AMD64, and installed to a clean hard disk. From reading, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    18

    Fresh Debian Install - Kde loading to blank screen


    Hi, linux newbie here looking for help with an install problem.

    I downloaded via BT the full DVD ISO's for etch/AMD64, and installed to a clean hard disk. From reading, I decided I might like KDE over Gnome, so I followed the installation instructions here (http://www.us.debian.org/releases/st...stall-software) and typed at the boot prompt
    Code:
    install tasks="standard, kde-desktop"
    The install appeared to go without a hitch, but upon rebooting, immediately after the boot sequence hits the line that loads KDE (I don't have it in front of me, but I think it says something like "initializing K Desktop Environment"), the screen goes blank. I let it sit there for about 3 minutes, then tried rebooting the system, same result. Tried double tapping ctrl-alt-del, various combinations of escape and ctr/alt, nothing happened.

    I'm running somewhat new hardware, but not bleeding edge, so I'd be surprised if it was lack of driver support for my video card (powercolor 9800XT) or monitor (samsung 17" with digital connect, don't have model # with me), both going on 3 yrs old.

    Thanks very much for any help or suggestions.

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Perhaps you can try to boot in "Recovery mode" (at boot prompt), and then reconfigure the X server:
    Code:
    dpkg-reconfigure xserver-xorg
    and choose the proper driver for your card, ie radeon (or ati, or vesa).
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Posts
    18
    Thank you! I'll try that out when I get home tonight. I knew there was a recovery console but wasn't sure how to go about loading it.

  4. #4
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    405
    I've had something similar to that happen when I upgraded on a Debian Testing system.

    This system had an old dual head Matrox card. This card would freeze up to a black screen when attempting to start X, and the hotkeys to switch to console mode had no effect (ctrl-alt-F1, F2, ..., or F6). The rest of the computer was fine; I could remotely log into the box and access nfs shares no problem. It's just the graphics card which was frozen up.

    This Matrox card worked fine with the "mga" driver before the upgrade, but the newer xorg driver suffered from the black screen hangup.

    I had actually seen this happen before, while trying to install Windows XP on a friend's computer. I was using this Matrox card, and every time it got to the point where it attempted to autodetect the graphics card, it froze to a black screen. I eventually tracked down info on the Internet that this was a known incompatability with the WinXP installer and that there was no way around it. Therefore, I put a different video card in that computer and kept the Matrox card for myself.

    Anyway, I solve the problem by editing /etc/X11/xorg.conf and replacing the "mga" driver with the generic "vesa" driver. The generic vesa driver isn't capable of 3d graphics hardware acceleration, but this old Matrox card doesn't have 3d hardware acceleration capability anyway.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  5. #5
    Just Joined!
    Join Date
    Apr 2007
    Posts
    18
    Thanks to your help I'm now posting from Konqueror in KDE

    Unfortunately, I found that the problem was occurring when I selected ATI for my graphics card (which it is, ATI Radeon 9800XT). So right now I'm using vesa as my selection. Any advice if there's a better driver which would work with an my card?

    Oh, also I did notice that I was a bit lost when it was prompting me for the PCI information. It defaulted to PCI:1:0:0 and seems to work as such. My card is connected via AGP, but maybe that's still considered a PCI bus? Not sure how to check the proper settings.

  6. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    For optimal performances, you may want to install the official ATI proprietary drivers:
    http://technowizah.com/2006/10/debia...i-drivers.html
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  7. #7
    Just Joined!
    Join Date
    Apr 2007
    Posts
    18
    Thanks yet again. I'll be trying that out tonight.

    I read elsewhere that you can install the ATI drivers through the Debian non-free packages. It sounds a bit easier for someone new like me. Is one method or the other any different or preferable?

  8. #8
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by Minstrel View Post
    Thanks yet again. I'll be trying that out tonight.

    I read elsewhere that you can install the ATI drivers through the Debian non-free packages. It sounds a bit easier for someone new like me. Is one method or the other any different or preferable?
    Yes, they are in the Debian non-free repositories. So if you use them, it may be a bit simpler that what is explained in the tutorial.

    Namely, here is what you would do.

    First, you need some package to compile the driver's module:
    Code:
    apt-get install fakeroot debhelper build-essential module-assistant
    Then you can install the drivers:
    Code:
    apt-get install fglrx-driver fglrx-kernel-src
    Install the kernel headers before compiling the fglrx kernel module:
    Code:
    apt-get install linux-headers-$(uname -r)
    Then compile the kernel module for the driver:
    Code:
    cd /usr/src
    sudo m-a prepare
    sudo m-a a-i fglrx
    Finally configure X properly, according to those instructions:
    http://www.stanchina.net/%7Eflavio/d...html#configure

    It may look complicated, but just go step by step, ensuring that each one is successful.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  9. #9
    Just Joined!
    Join Date
    Apr 2007
    Posts
    18
    Thank you, you've been invaluable in helping me get going on Linux. It's good to know I'll have a fully functional system talking properly to all my hardware as I can start to learn the basics.

  10. #10
    Just Joined!
    Join Date
    Apr 2007
    Posts
    18
    Everything went smooth as silk and I could tell it was working even without checking settings, much less window "streaking" when I move one window over another.

    There was no XF86Config-4 file, but it appeared xorg.conf was the same thing. Rather than manually editing, I ran
    Code:
    dpkg-reconfigure xserver-xorg
    and fglrx was now an option for a driver.

    My one remaining question was that the link you posted suggests having
    Code:
    Load "GLcore"
    in the file. It wasn't an option during the setup, and I'm wondering if it's worth it to manually edit it in. I have both grx and dri in the "Modules" section, along with about 6 other Load lines.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •