Find the answer to your Linux question:
Results 1 to 8 of 8
when i enter this command (to switch to us keyboard layout from dvorak): setxkbmap us i get this error message (this started happening after i started using lenny) : Xlib: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    85

    Xlib: connection to ":0.0" refused by server Xlib: No protocol specified


    when i enter this command (to switch to us keyboard layout from dvorak):

    setxkbmap us

    i get this error message (this started happening after i started using lenny) :

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    it also happened when i tried some other often used command, which i don't remember.

    i don't know if the following is related, but emacs is unable to locate the ruby.el file, even though it's right there in the emacs folder.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    is X-server (GUI) working properly?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    85
    there are no other symptoms that it isn't. how do i check?

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    are you executing that command in 'Command line mode' or in Konsole/Terminal of GUI? does Debian boot up in GUI mode? whats the output of 'startx' command?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Oct 2006
    Posts
    85
    kde starts up in gui mode, and i enter the command from a terminal in x.

    when i enter 'startx' (already running x), i get the following output:

    xauth: creating new authority file /root/.serverauth.3268
    xauth: creating new authority file /root/.Xauthority
    xauth: creating new authority file /root/.Xauthority

    X: warning; process set to priority -1 instead of requested priority 0

    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

    Xlib: connection to ":0.0" refused by server
    Xlib: Invalid MIT-MAGIC-COOKIE-1 key
    giving up.
    xinit: unable to connect to X server
    xinit: No such process (errno 3): Server error.


    the bottom four lines look like they represent an error that would be there even if x wasn't already running.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    are you executing 'su' command before 'setxkbmap'?
    this error pops up only if non-authorized user try to access X. 'root' login is disable in debian. in other words, 'root' user is not authorized to execute that command.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Oct 2006
    Posts
    85
    yes, i was 'su'. i tried it without being 'su', and it worked. thank you!

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    you are Welcome memius !

    check the manual of 'xhost' command. it allows non-authorized users to access X server temporarily.
    man xhost.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •