Find the answer to your Linux question:
Results 1 to 10 of 10
I have a bunch of TTF fonts from my last windows installation and some of them I would like to keep. How can I add them to this Debian 4.0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    45

    adding fonts


    I have a bunch of TTF fonts from my last windows installation
    and some of them I would like to keep.

    How can I add them to this Debian 4.0 etc installation and will they be available for all programs such as OOo 2.0 or do I also have to install them in OOo 2.0 and if so how?

    Thanks

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    The following method works on any Linux distro,
    Code:
    #mkdir /usr/share/fonts/msttf
    #cp /path/to/fonts/*.ttf /usr/share/fonts/msttf/.
    #cd /usr/share/fonts/msttf/
    #mkfontdir && mkfontscale
    You first create a directory in /usr/share/fonts (although the directory doesn't really need to be in /usr/share/fonts, I put it there because thats where other fonts reside) where you are going to store the truetype fonts. Copy the fonts to the directory you created and then make sure that the fonts in your directory are indexed. Logout and back again. All apps will then be able to use your fonts.

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    45
    It worked like a charm
    Tanks

    Ps is there a way to this like in windows when you open a folder with in a folder so it opens in the same folder rather than opening an other folder all the time?

    Thanks

  4. #4
    Just Joined!
    Join Date
    May 2007
    Posts
    45
    I think I have a problem
    i added more font rebooted and all the font that was associated with login and desktop icon were little white square and iceweasel did not want to start.
    So I deleted everything that was in the msttf and back to normal any recommendation?
    Thanks

  5. #5
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Quote Originally Posted by showgun View Post
    It worked like a charm
    Tanks

    Ps is there a way to this like in windows when you open a folder with in a folder so it opens in the same folder rather than opening an other folder all the time?

    Thanks
    If you don't like the nautilus spatial mode in GNOME, enter the command below
    Code:
    gconftool-2 --type bool --set /apps/nautilus/preferences/always_use_browser true
    Quote Originally Posted by showgun
    I think I have a problem
    i added more font rebooted and all the font that was associated with login and desktop icon were little white square and iceweasel did not want to start.
    So I deleted everything that was in the msttf and back to normal any recommendation?
    Thanks
    Sorry, I can't help with this one because I have never experienced such a problem before so don't know what maybe causing it.

  6. #6
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    406
    Don't you also need to add the "/usr/share/fonts/msttf" fontpath in /etc/X11/xorg.conf? I use a particular custom script for adding fonts to my Debian systems, but it's a bit ugly and gives me strange warning messages. I use a software package called "ttmkfdir", which I gather processes TrueType fonts or something.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  7. #7
    Just Joined!
    Join Date
    May 2007
    Posts
    45
    Hi guys I just install ttmkfdir as you suggested I also install a couple applets.
    Now I think what I will do is add one font at the time it might take me a few dayssss but I will see if some particular fonts are causing the problem or all of them.

    This is the only option I can think of doing.

  8. #8
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Quote Originally Posted by IsaacKuo View Post
    Don't you also need to add the "/usr/share/fonts/msttf" fontpath in /etc/X11/xorg.conf? I use a particular custom script for adding fonts to my Debian systems, but it's a bit ugly and gives me strange warning messages. I use a software package called "ttmkfdir", which I gather processes TrueType fonts or something.
    No, you do not need to add anything to your xorg.conf file if you use the method I mentioned above.

  9. #9
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Quote Originally Posted by showgun View Post
    Hi guys I just install ttmkfdir as you suggested I also install a couple applets.
    Now I think what I will do is add one font at the time it might take me a few dayssss but I will see if some particular fonts are causing the problem or all of them.

    This is the only option I can think of doing.
    When you add more fonts to the msttf directory, change into the directory and do the following
    Code:
    #rm fonts.cache fonts.scale 
    #mkfontdir && mkfontscale && fc-cache
    After that logout and back in again.

  10. #10
    Just Joined!
    Join Date
    May 2007
    Posts
    45
    Finally since I had not done the above procedure when I added more fonts before I decided to rm all the contents of the dir. and redid the procedure it works fine.
    I just realize why when I did the co command using the *.ttf not all the font.ttf got copied in the directory and it is because they are .TTF
    since LInux is precise in that manner I will have to pay extra attention to this <BG>

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •