Find the answer to your Linux question:
Results 1 to 2 of 2
I've been using the same process to upgrade & install Gnome on a Debian Woody install for ages, but I'm starting to have problems. My normal process is: Install Woody ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2

    Help: Installing Gnome on Testing / Unstable


    I've been using the same process to upgrade & install Gnome on a Debian Woody install for ages, but I'm starting to have problems.

    My normal process is:

    Install Woody from CD with C / C++ development & libncurses-dev
    Build new (2.6.6) kernel and install it

    Add stable APT sources to sources.list
    apt-get update
    apt-get upgrade

    Add unstable / testing APT sources to sources.list

    create /etc/apt/preferences containing:
    Package: *
    Pin: release a=testing
    Pin-Priority: 600

    Package: *
    Pin: release a=testing
    Pin-Priority: 50

    To upgrade, run:
    dselect update
    dselect select (just accept default & quit straight out)
    dselect install

    At this stage in the past, the system would be upgraded to testing/unstable, but it seems now that stuff like dhcp3-client is being removed. After dselect install ran, I re-installed dhcp3-client before I rebooted.

    I would then normally run:
    apt-get install gnome

    and that would install all of Gnome from testing/unstable. However, when I run the install apt-get barfs and complains about a bunch of stuff that wont be installed, such as gnome-office etc etc etc.

    To resolve this, I tried:
    apt-get dist-upgrade

    That upgraded a bunch of stuff. But when I go back to running apt-get install gnome, it complains only about gnome-office not being installed etc. I kluged it by running apt-get install gnome-office then apt-get install gnome, and that ran ok.

    I then installed gdm, xserver-xfree86, some fonts, gdm etc.

    However, the system wont run gdm or I get a weird broken Gnome...

    Is there something I'm now doing wrong, or any docs I should read. I've Googled about but can only find old instructions such as in Debian Reference etc.

    Heyelp!!

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2
    Update: I've installed Debian from the new Sarge installer which cuts out most of the hassle of upgrading Woody, but Gnome still seems broken.

    I'm guessing that this is something to do with the transtition of Gnome 2.6 into Sarge / Sid...

    I thought I'd leave it for a few days and try again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •