Find the answer to your Linux question:
Results 1 to 5 of 5
I had OpenSUSE 10.2 installed with a dual boot with XP. Everything worked fine but earlier this week I decided to reinstall to get rid of my XP partition and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848

    Help discovering what my problem lies


    I had OpenSUSE 10.2 installed with a dual boot with XP. Everything worked fine but earlier this week I decided to reinstall to get rid of my XP partition and free up some hard drive space.

    When I finished installing OpenSUSE I had no GUI. I tried startx but got the error:

    Code:
    morpheus:~ # startx
    xauth:  creating new authority file /root/.serverauth.4592
    
    This is a pre-release version of the X server from The X.Org Foundation.
    It is not supported in any way.
    Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
    Select the "xorg" product for bugs you find in this release.
    Before reporting bugs in pre-release versions please check the
    latest version in the X.Org Foundation git repository.
    See http://wiki.x.org/wiki/GitPage for git access instructions.
    
    X Window System Version 7.1.99.902 (7.2.0 RC 2)
    Release Date: 13 November 2006
    X Protocol Version 11, Revision 0, Release 7.1.99.902
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux morpheus 2.6.18.8-0.5-default #1 SMP Fri Jun 22 12:17:53 UTC 2007 i686
    Build Date: 05 April 2007
            Before reporting problems, check http://wiki.x.org
            to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug 29 23:32:39 2007
    (==) Using config file: "/etc/X11/xorg.conf"
    
    (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
    (EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
    (EE) NVIDIA(0):     that the NVIDIA device files have been created properly.
    (EE) NVIDIA(0):     Please consult the NVIDIA README for details.
    (EE) NVIDIA(0):  *** Aborting ***
    (EE) Screen(s) found, but none have a usable configuration.
    
    Fatal server error:
    no screens found
    XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
          after 0 requests (0 known processed) with 0 events remaining.
    After changing xorg.conf to use xorg.conf.saxsave in /exc/X11 I was able to get startx to work.

    However, something still isn't quite right. The screen is jumpy when I do things like scroll a web page. I have installed the latest drivers for my video card, a NVIDIA GeFORCE 7600 GT, just as I had on the previous installation.

    Any ideas what the problem could be?

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Did you reinstall the nVidia drivers? It sounds like you are either using the old xorg.conf without the driver installed or that the driver failed during installation.

  3. #3
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    Yes, that's the first thing I tried. I updated using NVIDIA - openSUSE

    The strangest thing is I didn't have this problem on my original instillation of OpenSUSE

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    Okay, I just reinstalled again and when asked to configure my hardware on the final page of the instalation I clicked skip. OpenSUSE has now booted into the GUI but I was met with the message:

    "Your monitor did not report its X and Y Size. This might cause display problems like unreadable fonts."

    Fonts are still readable but not as smooth as they should be. Clicking yes to the message opens SaX2: X11 Configuration and if I edit any of the settings, for instance turning down the resolution, and test them the test will fail.

    Anyone seen this at all?

  6. #5
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848

    Problem solved

    Yesterday I decided to download Fedora to see if the same happened. After burning the disk I realised that since my original installation of OpenSUSE I had started to use a KVM switch so my monitor wasn't connected directly to my computer.

    I removed the KVM switch and reinstalled OpenSUSE and everything is running fine now!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •