Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I use Suse 9.1 Personal wich comes only with KDE. I have downloaded and installed "fluxbox" as an RPM and it seems it is installed and working. But how do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2003
    Location
    /world/europe/sweden/örebro
    Posts
    37

    Alternative to KDE? How do I add one?


    I use Suse 9.1 Personal wich comes only with KDE.
    I have downloaded and installed "fluxbox" as an RPM and it seems it is installed and working. But how do I start it? At the login screen where I type my password there are no options. I used to use Mandrake 9.1 and there you could chose from a list, but there's no such list in Suse...or can I add one?
    Question: How do I add/start another window manager beside KDE?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What display manager is SuSE using? GDM, KDM or XDM?

  3. #3
    Just Joined!
    Join Date
    Nov 2003
    Location
    /world/europe/sweden/örebro
    Posts
    37
    don't know, how do I find out?

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Good question... can you post a screenshot or something? =)
    Alternatively, press Alt+F1, log in, run "ps -A | grep dm" and post what it returns.

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    1
    in SuSE 9.1 you can choose from the list by clicking on the Menu box, in the right of Login and then choosing a window manager from Session Type.

    Hope this helps,
    Becky

  6. #6
    Just Joined!
    Join Date
    Jun 2004
    Posts
    8
    Quote Originally Posted by iglitia
    in SuSE 9.1 you can choose from the list by clicking on the Menu box, in the right of Login and then choosing a window manager from Session Type.
    In SuSE 9.1 this is only available in the Pro version.
    Quote Originally Posted by Dolda2000
    What display manager is SuSE using? GDM, KDM or XDM?
    SuSE 9.1 Personal uses KDM by default.
    Quote Originally Posted by godspear
    Question: How do I add/start another window manager beside KDE?
    I am not aware of a hack that allows you to use select multiple WM's from the KDM login in SuSE 9.1 Personal. It might be out there but I've yet to locate where it's been demonstrated. My advice is to switch to GDM. It will allow you to select other WM's immediately and without any additional configuration.

  7. #7
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    you can of course select multiple windowmanagers from the kdm login.. and it certainly is not a "hack":)

    First, you need to edit the /opt/kde/share/config/kdm/kdmrc file.

    Code:
    pico /opt/kde/share/config/kdm/kdmrc
    when pico has loaded the file, use the down arrow on your keyboard to scroll through the file until you find the line that reads SessionTypes =. All you need to do here is append fluxbox, to the end of the line.

    It should look something like this:


    Code:
    SessionTypes=kde,gnome,failsafe,default,fluxbox,
    Now we'll need to edit the /usr/X11R6/lib/X11/xdm/Xsession file.

    Code:
     pico /usr/X11R6/lib/X11/xdm/Xsession
    Scroll down until you get to the case section. This section will contain your current window managers and will look something like this:

    Code:
    case "$1" in 
    failsafe) 
    xsetroot -solid SteelBlue 
    exec xterm -geometry 80x24-0-0 
    ;; 
    kde) 
    exec startkde 
    ;; 
    gnome) 
    exec gnome-session 
    ;;
    You will need to add the following code to the end of the case section:

    Code:
    fluxbox) 
    exec fluxbox 
    ;;
    This should be done in the same manner as all of the previous entries and should fit the flow nicely or else your config will be broken.

    That's all there is to it. All you have to do now is start KDM or, if you are in an existing window manager session, log out and then back in. Make sure to select the newly added Fluxbox entry from the drop-down list.

    That was taken from this document:

    http://www.madpenguin.org/cms/?m=show&id=325

    It is for slackware so some of the file locations might not be exactly the same in suse.

  8. #8
    Just Joined!
    Join Date
    Jun 2004
    Posts
    8
    Quote Originally Posted by variant
    you can of course select multiple windowmanagers from the kdm login.. and it certainly is not a "hack".
    But what the member is saying is that "At the login screen where I type my password there are no options." It's not just that they can't add fluxbox to the available list of WM's. There literally are no other WM's to choose from and no session options at login using KDM. The only option is KDE and that isn't even presented as a choice.

    If they were using the Pro version of 9.1 it would be an easy fix. But with the Personal version there is no session GUI in KDM from which to include another WM. Typical config methods won't alter the login GUI, which is really the issue here.

  9. #9
    Just Joined!
    Join Date
    Nov 2003
    Location
    /world/europe/sweden/örebro
    Posts
    37
    Thanx to you all who have helped.
    I finally decided to only edit some init-file and change the start mod to "3" instead of "5" wich gives me the oppertunity to login and then type: "startx fluxbox" for fluxbox, or just startx for KDE.

    I'll get the Pro version next time, it would save lot's of trouble...do you think Pro vill be released as ISO:s later?

  10. #10
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    Here is the "hack".

    Although I see the person asking the question is going to settle for the hard way, this thread comes up as the only source for information on suse 9.1 kdm session options.

    Everyone tells you to edit the sessiontypes but there is NO sessiontypes option. We'll have to add it, but that's not enough. So to help those who might come looking for the answer here it is:

    You need to edit your /etc/opt/kde3/share/config/kdm/kdmrc file as follows:

    first add your sessiontypes option. (extra given for context, you only need to add SessionTypes:

    [X-*-Greeter]
    SelectedUsers=
    SessionTypes=default,gnome,kde,icewm,failsafe
    ShowUsers=NotHidden


    Next you need to change:
    [X-:*-Greeter]
    AdminSession=YaSTadminSession
    HideMenu=True

    to:
    [X-:*-Greeter]
    AdminSession=YaSTadminSession
    HideMenu=false

    Yup, that hidemenu=true was why it was hiding the session types menu in KDM.

    Now you can add window managers as described by the poster above. You've now "hacked" your kdm to work like it does in pro.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •