Find the answer to your Linux question:
Results 1 to 5 of 5
Hello all, I currently installed debian linux and got X windows started. It seems that the default font system in debian is xfont-100dpi. I would like to either get rid ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    switching xfonts


    Hello all,

    I currently installed debian linux and got X windows started. It seems that the default font system in debian is xfont-100dpi. I would like to either get rid of this OR just let xfont-75dpi take over. In fact, when I tried to remove this with the apt command, it told me that it would also remove x-windows-system and x-windows-systemcore. I believe I need those packages so I didn't remove xfont-100dpi but I would very much like to get xfont75-dpi to work. Can anyone tell me what I need to in order for me to make this work?
    As always, all help is appreciated. Thank you.

    bp
    The best things in life are free.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I haven't experimented as much with X as I ought to have done. I think the font resolution is chosen by the client app in the first hand, but they usually leave it to the default. I would guess the default is the resolution that X believes that the screen is, but I'm not sure. If it is so, it's configurable in the XF86Config file, using the DisplaySize option in the Monitor section. You should of course check your font path settings as well. These are specified mainly in the XF86Config using the FontPath option in the Files section. This normally points to the font server, though, and its configuration is in /etc/X11/fs/config. The font server also has a "default-resolutions" entry, which you can check out. Maybe that's the default.

  3. #3
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    still not solved

    Dolda,

    I was looking at the file /etc/X11/XFrese86-4 and I don't see anything except the absolute path to both xfont-100dpi and x-font75dpi. When I was in redhat, all I had to do was get rid of xfont-100dpi using rpm commands but apt tells me to get rid of the x-window-system packages so I can't do that here.

    bp
    The best things in life are free.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Doesn't Debian use xfs? Strange... XFrese86-4, btw... what's up with that name; it's not even in the standard config search path of the X server? Debian seems to do some seriously strange stuff.
    Anyway, if you wanted to just remove the 100 DPI fonts, can't you just delete the line specifying them in XF86Config (or XFrese86-4...)

  6. #5
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    sucess or failure

    Dolda,

    First, I mistyped the file. It is XFree86-4. All I actually needed to do was comment out the 100dpi parts. But being the dumb a** that I am, I had to uninstall it. A lot of the users told me that was fine but now I'm experiencing problems with TTF. My emacs looks like it's drunk so I need to fix that. Everything else is pretty good and I'm soooo happy I made the switch. APT is freakin awsome.

    bp
    The best things in life are free.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •